aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/desktop-file-utils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/desktop-file-utils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/desktop-file-utils')
-rw-r--r--recipes/desktop-file-utils/desktop-file-utils-0.3/m4.patch65
-rw-r--r--recipes/desktop-file-utils/desktop-file-utils-native_0.14.bb12
-rw-r--r--recipes/desktop-file-utils/desktop-file-utils_0.3.bb10
-rw-r--r--recipes/desktop-file-utils/desktop-file-utils_0.6.bb9
4 files changed, 96 insertions, 0 deletions
diff --git a/recipes/desktop-file-utils/desktop-file-utils-0.3/m4.patch b/recipes/desktop-file-utils/desktop-file-utils-0.3/m4.patch
new file mode 100644
index 0000000000..38c53e16fe
--- /dev/null
+++ b/recipes/desktop-file-utils/desktop-file-utils-0.3/m4.patch
@@ -0,0 +1,65 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null
++++ desktop-file-utils-0.3/m4/pkg.m4
+@@ -0,0 +1,57 @@
++
++dnl PKG_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4, action-if, action-not)
++dnl defines GSTUFF_LIBS, GSTUFF_CFLAGS, see pkg-config man page
++dnl also defines GSTUFF_PKG_ERRORS on error
++AC_DEFUN(PKG_CHECK_MODULES, [
++ succeeded=no
++
++ if test -z "$PKG_CONFIG"; then
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++ fi
++
++ if test "$PKG_CONFIG" = "no" ; then
++ echo "*** The pkg-config script could not be found. Make sure it is"
++ echo "*** in your path, or set the PKG_CONFIG environment variable"
++ echo "*** to the full path to pkg-config."
++ echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
++ else
++ PKG_CONFIG_MIN_VERSION=0.9.0
++ if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
++ AC_MSG_CHECKING(for $2)
++
++ if $PKG_CONFIG --exists "$2" ; then
++ AC_MSG_RESULT(yes)
++ succeeded=yes
++
++ AC_MSG_CHECKING($1_CFLAGS)
++ $1_CFLAGS=`$PKG_CONFIG --cflags "$2"`
++ AC_MSG_RESULT($$1_CFLAGS)
++
++ AC_MSG_CHECKING($1_LIBS)
++ $1_LIBS=`$PKG_CONFIG --libs "$2"`
++ AC_MSG_RESULT($$1_LIBS)
++ else
++ $1_CFLAGS=""
++ $1_LIBS=""
++ ## If we have a custom action on failure, don't print errors, but
++ ## do set a variable so people can do so.
++ $1_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$2"`
++ ifelse([$4], ,echo $$1_PKG_ERRORS,)
++ fi
++
++ AC_SUBST($1_CFLAGS)
++ AC_SUBST($1_LIBS)
++ else
++ echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
++ echo "*** See http://www.freedesktop.org/software/pkgconfig"
++ fi
++ fi
++
++ if test $succeeded = yes; then
++ ifelse([$3], , :, [$3])
++ else
++ ifelse([$4], , AC_MSG_ERROR([Library requirements ($2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.]), [$4])
++ fi
++])
++
++
diff --git a/recipes/desktop-file-utils/desktop-file-utils-native_0.14.bb b/recipes/desktop-file-utils/desktop-file-utils-native_0.14.bb
new file mode 100644
index 0000000000..9603982ea6
--- /dev/null
+++ b/recipes/desktop-file-utils/desktop-file-utils-native_0.14.bb
@@ -0,0 +1,12 @@
+SECTION = "console/utils"
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/desktop-file-utils"
+DESCRIPTION = "command line utilities to work with *.desktop files"
+LICENSE = "GPL"
+
+DEPENDS = "glib-2.0-native"
+
+SRC_URI = "http://freedesktop.org/software/desktop-file-utils/releases/desktop-file-utils-${PV}.tar.gz"
+
+inherit autotools native
+
+S = "${WORKDIR}/desktop-file-utils-${PV}"
diff --git a/recipes/desktop-file-utils/desktop-file-utils_0.3.bb b/recipes/desktop-file-utils/desktop-file-utils_0.3.bb
new file mode 100644
index 0000000000..9bb74caf46
--- /dev/null
+++ b/recipes/desktop-file-utils/desktop-file-utils_0.3.bb
@@ -0,0 +1,10 @@
+SECTION = "console/utils"
+HOMEPAGE = "http://www.freedesktop.org/Software/desktop-file-utils"
+DESCRIPTION = "command line utilities to work with *.desktop files"
+LICENSE = "GPL"
+DEPENDS = "popt glib-2.0"
+
+SRC_URI = "http://freedesktop.org/Software/desktop-file-utils/releases/desktop-file-utils-${PV}.tar.gz \
+ file://m4.patch;patch=1"
+
+inherit autotools
diff --git a/recipes/desktop-file-utils/desktop-file-utils_0.6.bb b/recipes/desktop-file-utils/desktop-file-utils_0.6.bb
new file mode 100644
index 0000000000..f68dfa7423
--- /dev/null
+++ b/recipes/desktop-file-utils/desktop-file-utils_0.6.bb
@@ -0,0 +1,9 @@
+SECTION = "console/utils"
+HOMEPAGE = "http://www.freedesktop.org/Software/desktop-file-utils"
+DESCRIPTION = "command line utilities to work with *.desktop files"
+LICENSE = "GPL"
+DEPENDS = "popt glib-2.0 gnome-vfs"
+
+SRC_URI = "http://freedesktop.org/Software/desktop-file-utils/releases/desktop-file-utils-${PV}.tar.gz"
+
+inherit autotools