aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dhcp
diff options
context:
space:
mode:
authorPhilip Balister <philip@opensdr.com>2010-11-16 11:36:03 -0800
committerPhilip Balister <philip@opensdr.com>2010-11-18 12:09:37 -0800
commita528a922da0122af29152afc145c2dbfdbee0de1 (patch)
tree00a9ca961b0fd3fda832f3c4909a7a05fa9ba085 /recipes/dhcp
parentc2c8fe4c5629add94bd0b922f5b3446624a9f4d8 (diff)
downloadopenembedded-a528a922da0122af29152afc145c2dbfdbee0de1.tar.gz
dhcp : Create directory for state storage. Convert to INC_PR.
Diffstat (limited to 'recipes/dhcp')
-rw-r--r--recipes/dhcp/dhcp4.inc5
-rw-r--r--recipes/dhcp/dhcp_4.1.1-P1.bb2
2 files changed, 5 insertions, 2 deletions
diff --git a/recipes/dhcp/dhcp4.inc b/recipes/dhcp/dhcp4.inc
index e2b2658e01..c7bf06797e 100644
--- a/recipes/dhcp/dhcp4.inc
+++ b/recipes/dhcp/dhcp4.inc
@@ -4,6 +4,8 @@ HOMEPAGE = "http://www.isc.org/"
LICENSE = "ISC"
+INC_PR = "r1"
+
SRC_URI = "ftp://ftp.isc.org/isc/dhcp/dhcp-${PV}.tar.gz \
file://site.h \
file://init-relay file://default-relay \
@@ -26,6 +28,7 @@ do_install_append () {
install -d ${D}${sysconfdir}/init.d
install -d ${D}${sysconfdir}/default
install -d ${D}${sysconfdir}/dhcp
+ install -d ${D}${localstatedir}/lib/dhcp
install -m 0755 ${WORKDIR}/init-relay ${D}${sysconfdir}/init.d/dhcp-relay
install -m 0644 ${WORKDIR}/default-relay ${D}${sysconfdir}/default/dhcp-relay
install -m 0755 ${WORKDIR}/init-server ${D}${sysconfdir}/init.d/dhcp-server
@@ -46,7 +49,7 @@ FILES_${PN} = ""
FILES_dhcp-server = "${sbindir}/dhcpd ${sysconfdir}/init.d/dhcp-server ${sysconfdir}/default/dhcp-server ${sysconfdir}/dhcp/dhcpd.conf"
FILES_dhcp-relay = "${sbindir}/dhcrelay ${sysconfdir}/init.d/dhcp-relay ${sysconfdir}/default/dhcp-relay"
-FILES_dhcp-client = "${base_sbindir}/dhclient ${base_sbindir}/dhclient-script ${sysconfdir}/dhcp/dhclient.conf"
+FILES_dhcp-client = "${base_sbindir}/dhclient ${base_sbindir}/dhclient-script ${sysconfdir}/dhcp/dhclient.conf ${localstatedir}/lib/dhcp"
RDEPENDS_dhcp-client = "bash"
FILES_dhcp-omshell = "${bindir}/omshell"
diff --git a/recipes/dhcp/dhcp_4.1.1-P1.bb b/recipes/dhcp/dhcp_4.1.1-P1.bb
index ed5a31b7f2..0bbf50ccf2 100644
--- a/recipes/dhcp/dhcp_4.1.1-P1.bb
+++ b/recipes/dhcp/dhcp_4.1.1-P1.bb
@@ -1,6 +1,6 @@
require dhcp4.inc
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI += "file://fixincludes.patch \
file://dhcp-3.0.3-dhclient-dbus.patch;striplevel=0 \