aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dri
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-18 14:25:48 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-18 14:41:51 +0100
commit7c32647443c3e03890c3989f372f549296677d0c (patch)
treefc3bee5821b08c2815a3f7c7c55885f464db46e6 /recipes/dri
parentd939799c871d4279423841c149980fd1d61b5c7a (diff)
downloadopenembedded-7c32647443c3e03890c3989f372f549296677d0c.tar.gz
libdrm: add version 2.4.18
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/dri')
-rw-r--r--recipes/dri/libdrm_2.4.18.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/dri/libdrm_2.4.18.bb b/recipes/dri/libdrm_2.4.18.bb
new file mode 100644
index 0000000000..085a730861
--- /dev/null
+++ b/recipes/dri/libdrm_2.4.18.bb
@@ -0,0 +1,21 @@
+SECTION = "x11/base"
+DEPENDS = "libpthread-stubs"
+LICENSE = "MIT"
+SRC_URI = "http://dri.freedesktop.org/libdrm/libdrm-${PV}.tar.bz2;name=archive"
+PROVIDES = "drm"
+PR = "r0"
+
+SRC_URI[archive.md5sum] = "d2b5fbfd37742af7d2169f7d26ce3007"
+SRC_URI[archive.sha256sum] = "f6c5b44fff5cb602096cc48a1bced426496bc8060463c577a7d86f2e56eeb604"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'x86', '', '--disable-intel',d)}"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "${@base_contains('MACHINE_FEATURES', 'x86', '${PN}-intel', '',d)}"
+
+FILES_${PN}-intel = "${libdir}/libdrm_intel.so.*"