summaryrefslogtreecommitdiffstats
path: root/recipes/driftnet/driftnet-nogui-0.1.6
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/driftnet/driftnet-nogui-0.1.6
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/driftnet/driftnet-nogui-0.1.6')
-rw-r--r--recipes/driftnet/driftnet-nogui-0.1.6/arm.patch55
-rw-r--r--recipes/driftnet/driftnet-nogui-0.1.6/arm.patch.old49
2 files changed, 104 insertions, 0 deletions
diff --git a/recipes/driftnet/driftnet-nogui-0.1.6/arm.patch b/recipes/driftnet/driftnet-nogui-0.1.6/arm.patch
new file mode 100644
index 0000000000..ebb5fadd7c
--- /dev/null
+++ b/recipes/driftnet/driftnet-nogui-0.1.6/arm.patch
@@ -0,0 +1,55 @@
+--- driftnet-0.1.6/Makefile~ 2002-07-09 19:26:41.000000000 +0000
++++ driftnet-0.1.6/Makefile 2004-10-20 21:51:48.000000000 +0000
+@@ -13,14 +13,14 @@
+ #
+
+ # Compiler to use.
+-#CC = gcc
++CC = arm-linux-gcc
+
+ # Basic compiler, linker flags; should not need any changes.
+ CFLAGS += -g -Wall
+ LDFLAGS += -g
+
+ # You might need these if libpcap is installed somewhere random.
+-CFLAGS += -I/usr/include/pcap
++#CFLAGS += -I/usr/include/pcap
+ #LDFLAGS += -L/path/to/libpcap.so
+
+ # Required on Linux to get BSDish definitions of the TCP/IP structs.
+@@ -31,14 +31,14 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++#CFLAGS += `gtk-config --cflags`
++#LDLIBS += -ljpeg -lungif `gtk-config --libs`
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+ # use this, comment out the two preceding CFLAGS and LDLIBS lines and uncomment
+ # the following line:
+-#CFLAGS += -DNO_DISPLAY_WINDOW
++CFLAGS += -DNO_DISPLAY_WINDOW
+
+ # On systems with a C99 compiler, driftnet will use <stdint.h> for the
+ # definitions of types such as uint8_t. On other systems like Solaris, these
+@@ -81,7 +81,7 @@
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+ endianness: endian
+- ./endian > endianness
++
+
+ endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+@@ -103,7 +103,7 @@
+ mv driftnet-$(VERSION).tar.gz ..
+
+ depend: endianness
+- makedepend -- $(CFLAGS) `cat endianness` -- $(SRCS)
++ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+
diff --git a/recipes/driftnet/driftnet-nogui-0.1.6/arm.patch.old b/recipes/driftnet/driftnet-nogui-0.1.6/arm.patch.old
new file mode 100644
index 0000000000..fe0f08923c
--- /dev/null
+++ b/recipes/driftnet/driftnet-nogui-0.1.6/arm.patch.old
@@ -0,0 +1,49 @@
+--- ./driftnet-0.1.6/Makefile~ 2002-07-09 19:26:41.000000000 +0000
++++ ./driftnet-0.1.6/Makefile 2004-10-16 11:33:48.238088984 +0000
+@@ -13,7 +13,7 @@
+ #
+
+ # Compiler to use.
+-#CC = gcc
++CC = arm-linux-gcc
+
+ # Basic compiler, linker flags; should not need any changes.
+ CFLAGS += -g -Wall
+@@ -31,8 +31,8 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++#CFLAGS += `gtk-config --cflags`
++#LDLIBS += -ljpeg -lungif `gtk-config --libs`
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+@@ -43,7 +43,7 @@
+ # On systems with a C99 compiler, driftnet will use <stdint.h> for the
+ # definitions of types such as uint8_t. On other systems like Solaris, these
+ # are in <sys/types.h>, and you should uncomment this line.
+-#CFLAGS += -DUSE_SYS_TYPES_H
++CFLAGS += -DUSE_SYS_TYPES_H
+
+ # On Solaris, it is necessary to link against -lposix4 for the definition of
+ # nanosleep; uncomment the below.
+@@ -81,7 +81,7 @@
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+ endianness: endian
+- ./endian > endianness
++
+
+ endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+@@ -103,7 +103,7 @@
+ mv driftnet-$(VERSION).tar.gz ..
+
+ depend: endianness
+- makedepend -- $(CFLAGS) `cat endianness` -- $(SRCS)
++ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+