aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dsniff/dsniff_2.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dsniff/dsniff_2.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dsniff/dsniff_2.3.bb')
-rw-r--r--recipes/dsniff/dsniff_2.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/dsniff/dsniff_2.3.bb b/recipes/dsniff/dsniff_2.3.bb
new file mode 100644
index 0000000000..14da908b57
--- /dev/null
+++ b/recipes/dsniff/dsniff_2.3.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "dsniff is a collection of tools for network auditing and penetration testing."
+SECTION = "console/network"
+HOMEPAGE = "http://www.monkey.org/~dugsong/dsniff/"
+AUTHOR = "Dug Song <dugsong@monkey.org>"
+LICENSE = "BSD"
+PR = "r2"
+
+# There is a significant API change beween 1.0.2a of libnet and
+# 1.1.x, dsniff will only work with the older and there is no
+# updated version of dnsniff.
+DEPENDS = "virtual/db libpcap libnet-1.0 libnids openssl"
+
+SRC_URI = "\
+ http://www.monkey.org/~dugsong/dsniff/dsniff-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --without-x --with-db=${STAGING_LIBDIR}/.. \
+ --with-libpcap=${STAGING_LIBDIR}/.. \
+ --with-libnet=${STAGING_LIBDIR}/.. \
+ --with-libnids=${STAGING_LIBDIR}/.. \
+ --with-openssl=${STAGING_LIBDIR}/.. \
+"
+EXTRA_OEMAKE = "'install_prefix=${D}'"
+
+CFLAGS =+ "-I${S}/missing"
+LDFLAGS += "-lresolv"