aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ebtables/ebtables_2.0.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ebtables/ebtables_2.0.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ebtables/ebtables_2.0.6.bb')
-rw-r--r--recipes/ebtables/ebtables_2.0.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/ebtables/ebtables_2.0.6.bb b/recipes/ebtables/ebtables_2.0.6.bb
new file mode 100644
index 0000000000..33ad2b9113
--- /dev/null
+++ b/recipes/ebtables/ebtables_2.0.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Utility that enables basic Ethernet frame filtering on a Linux bridge, MAC NAT and brouting."
+PRIORITY = "optional"
+LICENSE = "GPL"
+SECTION = "console/network"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ebtables/ebtables-v${PV}.tar.gz \
+ file://gcc34.patch;patch=1 \
+ file://gcc4.patch;patch=1 \
+ file://installnonroot.patch;patch=1 \
+ file://installcreatedirs.patch;patch=1"
+S = "${WORKDIR}/ebtables-v${PV}"
+
+do_compile () {
+ oe_runmake 'BINPATH=/sbin/' 'MANDIR=${mandir}/' \
+ 'ETHERTYPESPATH=${sysconfdir}/' 'KERNEL_INCLUDES=${STAGING_INCDIR}'
+}
+
+do_install () {
+ oe_runmake 'BINPATH=${D}${base_sbindir}/' 'MANDIR=${D}${mandir}/' \
+ 'ETHERTYPESPATH=${D}${sysconfdir}/' install
+}