aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ecj
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2010-05-15 23:41:19 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-05-16 00:27:12 +0200
commit0664036a821f0e9384e1ccbbed24f74055c04968 (patch)
treea1a81be26bf861bb8fa015fd80587a46de3ab072 /recipes/ecj
parent47f8089db47a385ad8627af9cb4d707eb9d2c5d8 (diff)
downloadopenembedded-0664036a821f0e9384e1ccbbed24f74055c04968.tar.gz
ecj-bootstrap-native: convert to new staging system
Diffstat (limited to 'recipes/ecj')
-rw-r--r--recipes/ecj/ecj-bootstrap-native.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/ecj/ecj-bootstrap-native.bb b/recipes/ecj/ecj-bootstrap-native.bb
index 6c80de749a..594b08cb9c 100644
--- a/recipes/ecj/ecj-bootstrap-native.bb
+++ b/recipes/ecj/ecj-bootstrap-native.bb
@@ -21,6 +21,8 @@ PR = "r2"
JAR = "ecj-bootstrap.jar"
+NATIVE_INSTALL_WORKS = "1"
+
inherit native
do_compile() {
@@ -31,8 +33,8 @@ do_compile() {
cat ecj.in >> ecj-bootstrap
}
-do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
- install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${S}/ecj-bootstrap ${D}${bindir}
+ install -m 755 ${S}/ecj-bootstrap ${D}${bindir}/javac
}