aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ed
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-26 12:14:52 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-26 12:15:41 -0700
commit46cb2fc3622d7dc444ac2860e10dc55d96061ac6 (patch)
tree3d05604acd22e88a4ea83bf4d996fc91590a9ac4 /recipes/ed
parent77c46353c6836668b67c28691279177ccce8d483 (diff)
downloadopenembedded-46cb2fc3622d7dc444ac2860e10dc55d96061ac6.tar.gz
ed: add recipes, version 0.5 and 1.5
0.5 was the last version to be GPLv2+, so I'm including that in addition to the latest GPLv3+ version. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/ed')
-rw-r--r--recipes/ed/ed.inc25
-rw-r--r--recipes/ed/ed_0.5.bb8
-rw-r--r--recipes/ed/ed_1.5.bb8
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes/ed/ed.inc b/recipes/ed/ed.inc
new file mode 100644
index 0000000000..5372c0f1ae
--- /dev/null
+++ b/recipes/ed/ed.inc
@@ -0,0 +1,25 @@
+DESCRIPTION = "GNU ed is a line-oriented text editor"
+HOMEPAGE = "http://www.gnu.org/software/ed/"
+INC_PR = "0"
+
+CONFIGUREOPTS = "\
+ '--srcdir=${S}' \
+ '--prefix=${prefix}' \
+ '--exec-prefix=${exec_prefix}' \
+ '--bindir=${bindir}' \
+ '--datadir=${datadir}' \
+ '--infodir=${infodir}' \
+ '--sysconfdir=${sysconfdir}' \
+ 'CXX=${CXX}' \
+ 'CPPFLAGS=${CPPFLAGS}' \
+ 'CXXFLAGS=${CXXFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+EXTRA_OEMAKE = ""
+
+B = "${S}/obj"
+do_configure () {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes/ed/ed_0.5.bb b/recipes/ed/ed_0.5.bb
new file mode 100644
index 0000000000..a50e655ec8
--- /dev/null
+++ b/recipes/ed/ed_0.5.bb
@@ -0,0 +1,8 @@
+require ed.inc
+
+LICENSE = "GPLv2+"
+PR = "${INC_PR}.0"
+
+SRC_URI = "${SAVANNAH_MIRROR}/releases/ed/ed-${PV}.tar.bz2"
+SRC_URI[md5sum] = "4ee21e9dcc9b5b6012c23038734e1632"
+SRC_URI[sha256sum] = "edef2bbde0fbf0d88232782a0eded323f483a0519d6fde9a3b1809056fd35f3e"
diff --git a/recipes/ed/ed_1.5.bb b/recipes/ed/ed_1.5.bb
new file mode 100644
index 0000000000..49e619f366
--- /dev/null
+++ b/recipes/ed/ed_1.5.bb
@@ -0,0 +1,8 @@
+require ed.inc
+
+LICENSE = "GPLv3+"
+PR = "${INC_PR}.0"
+
+SRC_URI = "${GNU_MIRROR}/ed/ed-${PV}.tar.gz"
+SRC_URI[md5sum] = "e66c03d7e4c67b025d5b6093ec678267"
+SRC_URI[sha256sum] = "97dd34a49ebc9c97e414b90a087d63eafc41377a340848c97e75a9cba187fba1"