summaryrefslogtreecommitdiffstats
path: root/recipes/eel
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/eel
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/eel')
-rw-r--r--recipes/eel/eel/configure.patch42
-rw-r--r--recipes/eel/eel/eel-no-strftime.patch29
-rw-r--r--recipes/eel/eel_2.12.2.bb16
-rw-r--r--recipes/eel/eel_2.22.2.bb16
-rw-r--r--recipes/eel/eel_2.24.1.bb16
-rw-r--r--recipes/eel/eel_2.6.1.bb45
6 files changed, 164 insertions, 0 deletions
diff --git a/recipes/eel/eel/configure.patch b/recipes/eel/eel/configure.patch
new file mode 100644
index 0000000000..594a753535
--- /dev/null
+++ b/recipes/eel/eel/configure.patch
@@ -0,0 +1,42 @@
+--- eel-2.6.1/configure.in 2004-04-19 03:54:15.000000000 -0700
++++ eel-2.6.1.new/configure.in 2004-11-12 17:48:40.272719976 -0700
+@@ -87,21 +87,25 @@
+ dnl ===========================================================================
+
+ dnl strftime checks
++dnl grrrr... this doesn't work for cross compiling
++dnl define it for OE
+
+-AC_TRY_RUN([#include <time.h>
+- int main ()
+- {
+- char buf[100];
+- struct tm tm = {0};
+- tm.tm_year = 99;
+- if (strftime(buf, 100, "%EY", &tm) == 4 &&
+- strcmp (buf, "1999")==0)
+- return 0;
+- return 1;
+- }
+- ],
+- AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
+- )
++AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
++dnl )
++dnl AC_TRY_RUN([#include <time.h>
++dnl int main ()
++dnl {
++dnl char buf[100];
++dnl struct tm tm = {0};
++dnl tm.tm_year = 99;
++dnl if (strftime(buf, 100, "%EY", &tm) == 4 &&
++dnl strcmp (buf, "1999")==0)
++dnl return 0;
++dnl return 1;
++dnl }
++dnl ],
++dnl AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
++dnl )
+
+ dnl ===========================================================================
+
diff --git a/recipes/eel/eel/eel-no-strftime.patch b/recipes/eel/eel/eel-no-strftime.patch
new file mode 100644
index 0000000000..a5795e573e
--- /dev/null
+++ b/recipes/eel/eel/eel-no-strftime.patch
@@ -0,0 +1,29 @@
+--- /tmp/configure.in 2008-09-05 14:01:25.000000000 +0200
++++ eel-2.22.2/configure.in 2008-09-05 14:01:58.693198000 +0200
+@@ -98,26 +98,6 @@
+
+
+
+-dnl ===========================================================================
+-
+-dnl strftime checks
+-
+-AC_TRY_RUN([#include <time.h>
+- int main ()
+- {
+- char buf[100];
+- struct tm tm = {0};
+- tm.tm_year = 99;
+- if (strftime(buf, 100, "%EY", &tm) == 4 &&
+- strcmp (buf, "1999")==0)
+- return 0;
+- return 1;
+- }
+- ],
+- AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
+- )
+-
+-dnl ===========================================================================
+
+ dnl X development libraries check
+
diff --git a/recipes/eel/eel_2.12.2.bb b/recipes/eel/eel_2.12.2.bb
new file mode 100644
index 0000000000..92bfc88f46
--- /dev/null
+++ b/recipes/eel/eel_2.12.2.bb
@@ -0,0 +1,16 @@
+# eel OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+LICENSE="GPL"
+SRC_URI += "file://configure.patch;patch=1"
+
+DEPENDS = "gnome-vfs gnome-desktop gnome-menus libgnomeui gail"
+EXTRA_OECONF = "--disable-gtk-doc"
+
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/recipes/eel/eel_2.22.2.bb b/recipes/eel/eel_2.22.2.bb
new file mode 100644
index 0000000000..04353795c3
--- /dev/null
+++ b/recipes/eel/eel_2.22.2.bb
@@ -0,0 +1,16 @@
+# eel OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+LICENSE="GPL"
+
+SRC_URI += "file://eel-no-strftime.patch;patch=1"
+
+DEPENDS = "gnome-vfs gnome-desktop gnome-menus libgnomeui gail"
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/eel/eel_2.24.1.bb b/recipes/eel/eel_2.24.1.bb
new file mode 100644
index 0000000000..04353795c3
--- /dev/null
+++ b/recipes/eel/eel_2.24.1.bb
@@ -0,0 +1,16 @@
+# eel OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+LICENSE="GPL"
+
+SRC_URI += "file://eel-no-strftime.patch;patch=1"
+
+DEPENDS = "gnome-vfs gnome-desktop gnome-menus libgnomeui gail"
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/eel/eel_2.6.1.bb b/recipes/eel/eel_2.6.1.bb
new file mode 100644
index 0000000000..f123a4aa93
--- /dev/null
+++ b/recipes/eel/eel_2.6.1.bb
@@ -0,0 +1,45 @@
+# eel OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+LICENSE="GPL"
+SRC_URI += "file://configure.patch;patch=1"
+
+DEPENDS="libgnomeui gail"
+EXTRA_OECONF = "--disable-gtk-doc"
+
+edir="${STAGING_INCDIR}/eel-2/eel"
+
+headers="eel-accessibility.h eel-graphic-effects.h \
+ eel-alert-dialog.h eel-gtk-container.h \
+ eel-art-extensions.h eel-gtk-extensions.h \
+ eel-art-gtk-extensions.h eel-gtk-macros.h \
+ eel-background-box.h eel-i18n.h \
+ eel-background.h eel-image-table.h \
+ eel-canvas-rect-ellipse.h eel-labeled-image.h \
+ eel-canvas-util.h eel-marshal.h \
+ eel-canvas.h eel-pango-extensions.h \
+ eel-cell-renderer-pixbuf-list.h eel-preferences-glade.h \
+ eel-dateedit-extensions.h eel-preferences.h \
+ eel-debug-drawing.h eel-self-checks.h \
+ eel-debug.h eel-stock-dialogs.h \
+ eel-editable-label.h eel-string-list.h \
+ eel-ellipsizing-label.h eel-string.h \
+ eel-enumeration.h eel-type-builtins.h \
+ eel-features.h eel-types.h \
+ eel-gconf-extensions.h eel-vfs-extensions.h \
+ eel-gdk-extensions.h eel-wrap-table.h \
+ eel-gdk-pixbuf-extensions.h eel-xml-extensions.h \
+ eel-glib-extensions.h eel.h \
+ eel-gnome-extensions.h"
+
+do_stage() {
+ install -d ${edir}
+ for file in ${headers}; do
+ install -m 0644 eel/$file ${edir}/$file
+ done
+
+ oe_libinstall -C eel libeel-2 ${STAGING_LIBDIR}
+}