aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-24 14:51:07 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-24 14:51:07 +0200
commitadf66c30a6946741462d0274aef624880fb40810 (patch)
tree07024e998605803b94df0bba3c455fe40f16c8d1 /recipes/efl1
parentbdc8f0323b05966c3533ab72614ddafe257a8352 (diff)
downloadopenembedded-adf66c30a6946741462d0274aef624880fb40810.tar.gz
enlightenment: bump SRCREV
* runtime tested on angstrom/beagleboard * upgrade paths intact and working
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/ecore.inc5
-rw-r--r--recipes/efl1/edje-native_svn.bb2
-rw-r--r--recipes/efl1/edje_svn.bb13
3 files changed, 18 insertions, 2 deletions
diff --git a/recipes/efl1/ecore.inc b/recipes/efl1/ecore.inc
index facd7a231a..0ebddd56dc 100644
--- a/recipes/efl1/ecore.inc
+++ b/recipes/efl1/ecore.inc
@@ -8,6 +8,11 @@ PR = "r3"
inherit efl
+do_configure_prepend() {
+ touch ${S}/po/Makefile.in.in || true
+ sed -i -e 's: po::g' ${S}/Makefile.am
+}
+
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ecore"
PACKAGES =+ "\
diff --git a/recipes/efl1/edje-native_svn.bb b/recipes/efl1/edje-native_svn.bb
index e7650cd639..7b4b79a300 100644
--- a/recipes/efl1/edje-native_svn.bb
+++ b/recipes/efl1/edje-native_svn.bb
@@ -2,7 +2,7 @@ require edje_${PV}.bb
inherit native
PR = "r3"
-DEPENDS = "evas-native ecore-native eet-native embryo-native"
+DEPENDS = "lua5.1-native evas-native ecore-native eet-native embryo-native"
do_configure_prepend() {
sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
diff --git a/recipes/efl1/edje_svn.bb b/recipes/efl1/edje_svn.bb
index 7f94b08256..bfd00ecb96 100644
--- a/recipes/efl1/edje_svn.bb
+++ b/recipes/efl1/edje_svn.bb
@@ -1,11 +1,22 @@
DESCRIPTION = "Edje is the Enlightenment graphical design & layout library"
-DEPENDS = "eet evas ecore embryo edje-native"
+DEPENDS = "lua5.1 eet evas ecore embryo edje-native"
LICENSE = "MIT BSD"
PV = "0.9.92.060+svnr${SRCREV}"
PR = "r4"
inherit efl
+# The new lua stuff is a bit broken...
+do_configure_append() {
+ for i in $(find "${S}" -name "Makefile") ; do
+ sed -i -e 's:-L/usr/local/lib::g' $i
+ done
+}
+
+do_compile_append() {
+ sed -i -e s:local/::g -e 's:-L${STAGING_LIBDIR}::g' ${S}/edje.pc
+}
+
# gain some extra performance at the expense of RAM - generally i'd say bad
# and a possible source of bugs
#EXTRA_OECONF = "--enable-edje-program-cache"