aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eglibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-05-06 00:43:04 -0700
committerKhem Raj <raj.khem@gmail.com>2010-05-06 00:48:17 -0700
commit4134f55dc7d99516d750b24a60e5cec400ae5ef3 (patch)
tree4ead6c49e5c56a774d4cd10d195f66066aa0f2b6 /recipes/eglibc
parentb1f53557c586db2e73b06ab5f7912c195527f291 (diff)
downloadopenembedded-4134f55dc7d99516d750b24a60e5cec400ae5ef3.tar.gz
eglibc: Move away from legacy staging.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/eglibc')
-rw-r--r--recipes/eglibc/eglibc-initial.inc32
-rw-r--r--recipes/eglibc/eglibc-stage.inc6
-rw-r--r--recipes/eglibc/eglibc_2.10.bb2
-rw-r--r--recipes/eglibc/eglibc_2.11.bb2
-rw-r--r--recipes/eglibc/eglibc_2.9.bb2
-rw-r--r--recipes/eglibc/eglibc_svn.bb2
6 files changed, 19 insertions, 27 deletions
diff --git a/recipes/eglibc/eglibc-initial.inc b/recipes/eglibc/eglibc-initial.inc
index 7a5a7b22f4..eb765df178 100644
--- a/recipes/eglibc/eglibc-initial.inc
+++ b/recipes/eglibc/eglibc-initial.inc
@@ -13,7 +13,7 @@ do_configure () {
${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
--prefix=/usr \
--without-cvs --disable-sanity-checks \
- --with-headers=${STAGING_DIR_TARGET}${layout_includedir} \
+ --with-headers=${STAGING_DIR_TARGET}${includedir} \
--enable-hacker-mode --enable-addons
}
@@ -21,18 +21,24 @@ do_compile () {
:
}
-do_stage () {
- oe_runmake cross-compiling=yes install_root=${STAGING_DIR_HOST} \
- includedir='${layout_includedir}' prefix='${layout_prefix}' install-headers \
- install-bootstrap-headers=yes
- oe_runmake csu/subdir_lib
+do_install () {
+ oe_runmake cross-compiling=yes install_root=${D} \
+ includedir='${includedir}' prefix='${prefix}' \
+ install-bootstrap-headers=yes install-headers
- mkdir -p ${STAGING_DIR_TARGET}${layout_libdir}
- install -m 644 csu/crt[1in].o ${STAGING_DIR_TARGET}${layout_libdir}
- ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \
- -o ${STAGING_DIR_TARGET}${layout_libdir}/libc.so
-}
+ oe_runmake csu/subdir_lib
+ # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
+ # so do them by hand. We can tolerate an empty stubs.h for the moment.
+ # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
+ mkdir -p ${D}${includedir}/gnu/
+ touch ${D}${includedir}/gnu/stubs.h
+ cp ${S}/include/features.h ${D}${includedir}/features.h
-do_install () {
- :
+ if [ -e ${B}/bits/stdio_lim.h ]; then
+ cp ${B}/bits/stdio_lim.h ${D}${includedir}/bits/
+ fi
+ mkdir -p ${D}${libdir}/
+ install -m 644 csu/crt[1in].o ${D}${libdir}
+ ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \
+ -o ${D}${libdir}/libc.so
}
diff --git a/recipes/eglibc/eglibc-stage.inc b/recipes/eglibc/eglibc-stage.inc
deleted file mode 100644
index 79ca8c8ca1..0000000000
--- a/recipes/eglibc/eglibc-stage.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-do_stage() {
- # Installing directly into staging creates some races between existing
- # glibc-initial files and us. We could use a new DESTDIR but we may as
- # well just copy the data installed by do_install
- cp -pPR ${D}/* ${STAGING_DIR_HOST}/
-}
diff --git a/recipes/eglibc/eglibc_2.10.bb b/recipes/eglibc/eglibc_2.10.bb
index a65a2bf304..150d77598b 100644
--- a/recipes/eglibc/eglibc_2.10.bb
+++ b/recipes/eglibc/eglibc_2.10.bb
@@ -96,6 +96,4 @@ do_compile () {
)
}
-require eglibc-stage.inc
-
require eglibc-package.bbclass
diff --git a/recipes/eglibc/eglibc_2.11.bb b/recipes/eglibc/eglibc_2.11.bb
index 6d78bde69e..63f70c2af4 100644
--- a/recipes/eglibc/eglibc_2.11.bb
+++ b/recipes/eglibc/eglibc_2.11.bb
@@ -96,6 +96,4 @@ do_compile () {
)
}
-require eglibc-stage.inc
-
require eglibc-package.bbclass
diff --git a/recipes/eglibc/eglibc_2.9.bb b/recipes/eglibc/eglibc_2.9.bb
index 031f1127f3..914bc77d1f 100644
--- a/recipes/eglibc/eglibc_2.9.bb
+++ b/recipes/eglibc/eglibc_2.9.bb
@@ -96,6 +96,4 @@ do_compile () {
)
}
-require eglibc-stage.inc
-
require eglibc-package.bbclass
diff --git a/recipes/eglibc/eglibc_svn.bb b/recipes/eglibc/eglibc_svn.bb
index f4ca256d88..f15160efa5 100644
--- a/recipes/eglibc/eglibc_svn.bb
+++ b/recipes/eglibc/eglibc_svn.bb
@@ -95,6 +95,4 @@ do_compile () {
)
}
-require eglibc-stage.inc
-
require eglibc-package.bbclass