aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eglibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-03-31 21:57:21 -0700
committerKhem Raj <raj.khem@gmail.com>2010-04-01 14:22:59 -0700
commitb311e10ca11856ba052ad32e041af1ec3479b0b9 (patch)
treebba8e17144fc5e1dca7b672ddb2e579f126426a3 /recipes/eglibc
parent5eb571a0a5b24c3833e806aba938aad39ea10f08 (diff)
downloadopenembedded-b311e10ca11856ba052ad32e041af1ec3479b0b9.tar.gz
eglibc: Add patch to limit gcc commandline output.
* This patch reduced the size of do_compile of eglibc from 12M to 5.4M and the build time for eglibc improved a bit too * The patch applied to 2.9,2.10 and 2.11 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/eglibc')
-rw-r--r--recipes/eglibc/eglibc_2.10.bb3
-rw-r--r--recipes/eglibc/eglibc_2.11.bb3
-rw-r--r--recipes/eglibc/eglibc_2.9.bb3
-rw-r--r--recipes/eglibc/files/shorten-build-commands.patch79
4 files changed, 85 insertions, 3 deletions
diff --git a/recipes/eglibc/eglibc_2.10.bb b/recipes/eglibc/eglibc_2.10.bb
index 4dfaccfb15..a65a2bf304 100644
--- a/recipes/eglibc/eglibc_2.10.bb
+++ b/recipes/eglibc/eglibc_2.10.bb
@@ -3,13 +3,14 @@ require eglibc.inc
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.10"
-PR = "${INC_PR}.8"
+PR = "${INC_PR}.9"
SVN_REV="10152"
EGLIBC_BRANCH="eglibc-2_10"
SRC_URI = "svn://svn.eglibc.org/branches;module=${EGLIBC_BRANCH};rev=${SVN_REV};proto=svn \
file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
file://armv4t-interworking.patch;patch=1 \
file://IO-acquire-lock-fix.patch;patch=1 \
+ file://shorten-build-commands.patch;patch=1 \
file://etc/ld.so.conf \
file://generate-supported.mk"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
diff --git a/recipes/eglibc/eglibc_2.11.bb b/recipes/eglibc/eglibc_2.11.bb
index 6a417055cf..6d78bde69e 100644
--- a/recipes/eglibc/eglibc_2.11.bb
+++ b/recipes/eglibc/eglibc_2.11.bb
@@ -4,12 +4,13 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.11"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
SVN_REV="10151"
EGLIBC_BRANCH="eglibc-2_11"
SRC_URI = "svn://svn.eglibc.org/branches;module=${EGLIBC_BRANCH};rev=${SVN_REV};proto=svn \
file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
file://IO-acquire-lock-fix.patch;patch=1 \
+ file://shorten-build-commands.patch;patch=1 \
file://etc/ld.so.conf \
file://generate-supported.mk"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
diff --git a/recipes/eglibc/eglibc_2.9.bb b/recipes/eglibc/eglibc_2.9.bb
index 37e29c019d..031f1127f3 100644
--- a/recipes/eglibc/eglibc_2.9.bb
+++ b/recipes/eglibc/eglibc_2.9.bb
@@ -3,13 +3,14 @@ require eglibc.inc
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.9"
-PR = "${INC_PR}.8"
+PR = "${INC_PR}.9"
SVN_REV="10153"
EGLIBC_BRANCH="eglibc-2_9"
SRC_URI = "svn://svn.eglibc.org/branches;module=${EGLIBC_BRANCH};rev=${SVN_REV};proto=svn \
file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
file://armv4t-interworking.patch;patch=1 \
file://IO-acquire-lock-fix.patch;patch=1 \
+ file://shorten-build-commands.patch;patch=1 \
file://etc/ld.so.conf \
file://generate-supported.mk"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
diff --git a/recipes/eglibc/files/shorten-build-commands.patch b/recipes/eglibc/files/shorten-build-commands.patch
new file mode 100644
index 0000000000..57835adcdb
--- /dev/null
+++ b/recipes/eglibc/files/shorten-build-commands.patch
@@ -0,0 +1,79 @@
+Source: http://sourceware.org/ml/libc-alpha/2010-03/msg00064.html
+
+This patch scratches an itch. Each individual gcc command in the
+glibc build is over 1K, which means it takes up a good chunk of my
+terminal. Most of that is include paths. Any version of GCC new
+enough to build glibc supports response files, which were added in
+2005. So use a response file for the static list of include paths.
+Now the build commands are a lot shorter, and easier to use when
+developing glibc.
+
+Tested on x86_64-linux-gnu. Please apply if acceptable.
+
+--
+Daniel Jacobowitz
+CodeSourcery
+
+2010-03-30 Daniel Jacobowitz <dan@codesourcery.com>
+
+ * Makeconfig (+common-includes): Define.
+ (+includes): Use @$(common-objpfx)includes.
+ * Makefile (postclean): Remove includes and includes.mk.
+ * Makerules ($(common-objpfx)includes.mk): Include and create
+ includes.mk. Create includes.
+
+Index: libc/Makeconfig
+===================================================================
+--- libc.orig/Makeconfig 2009-10-13 22:55:12.000000000 -0700
++++ libc/Makeconfig 2010-03-31 16:02:37.120489733 -0700
+@@ -678,9 +678,10 @@ endif # $(+cflags) == ""
+ # library source directory, in the include directory, and in the
+ # current directory.
+ +sysdep-includes = $(addprefix -I,$(+sysdep_dirs))
+++common-includes = $(+sysdep-includes) $(includes) $(sysincludes)
+ +includes = -I$(..)include $(if $(subdir),$(objpfx:%/=-I%)) \
+- $(+sysdep-includes) $(includes) \
+- $(patsubst %/,-I%,$(..)) $(libio-include) -I. $(sysincludes)
++ @$(common-objpfx)includes \
++ $(patsubst %/,-I%,$(..)) $(libio-include) -I.
+
+ # Since libio has several internal header files, we use a -I instead
+ # of many little headers in the include directory.
+Index: libc/Makefile
+===================================================================
+--- libc.orig/Makefile 2009-12-09 12:06:28.000000000 -0800
++++ libc/Makefile 2010-03-31 16:02:37.132481508 -0700
+@@ -247,7 +247,7 @@ parent-mostlyclean: common-mostlyclean #
+ parent-clean: parent-mostlyclean common-clean
+
+ postclean = $(addprefix $(common-objpfx),$(postclean-generated)) \
+- $(addprefix $(objpfx),sysd-dirs sysd-rules) \
++ $(addprefix $(objpfx),sysd-dirs sysd-rules includes includes.mk) \
+ $(addprefix $(objpfx),sysd-sorted soversions.mk soversions.i)
+
+ clean: parent-clean
+Index: libc/Makerules
+===================================================================
+--- libc.orig/Makerules 2009-12-09 12:06:28.000000000 -0800
++++ libc/Makerules 2010-03-31 16:02:37.140481645 -0700
+@@ -254,6 +254,20 @@ ifndef sysd-rules-done
+ no_deps=t
+ endif
+
++-include $(common-objpfx)includes.mk
++ifneq ($(+common-includes),$(saved-includes))
++# Recreate includes.mk (and includes).
++includes-force = FORCE
++FORCE:
++endif
++$(common-objpfx)includes.mk: $(includes-force)
++ -@rm -f $@T $(common-objpfx)includesT
++ for inc in $(+common-includes); do echo "$$inc"; done \
++ > $(common-objpfx)includesT
++ mv -f $(common-objpfx)includesT $(common-objpfx)includes
++ echo 'saved-includes := $(+common-includes)' > $@T
++ mv -f $@T $@
++
+ define o-iterator-doit
+ $(objpfx)%$o: %.S $(before-compile); $$(compile-command.S)
+ endef