aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eglibc
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-06-26 11:17:53 -0400
committerTom Rini <trini@embeddedalley.com>2009-06-26 11:17:53 -0400
commit83f41716ab6a2a9d83d4ff044dcef00595ecfeb2 (patch)
tree212509c0c4a77967e27ccb8d9f2001035e01843f /recipes/eglibc
parent9bc5c3798ed03beaa6a676533f6101cd271272fe (diff)
downloadopenembedded-83f41716ab6a2a9d83d4ff044dcef00595ecfeb2.tar.gz
eglibc: Make sure that scsi headers are available when needed
This is fixing bug #4262 for eglibc (original did glibc and linux-libc-headers). See b8bb2a62b3916470c752bd79d31322b4358fc676 for the rest of this.
Diffstat (limited to 'recipes/eglibc')
-rw-r--r--recipes/eglibc/eglibc-package.bbclass3
-rw-r--r--recipes/eglibc/eglibc.inc1
-rw-r--r--recipes/eglibc/eglibc_2.9.bb2
-rw-r--r--recipes/eglibc/eglibc_svn.bb2
4 files changed, 3 insertions, 5 deletions
diff --git a/recipes/eglibc/eglibc-package.bbclass b/recipes/eglibc/eglibc-package.bbclass
index f2acc961fa..d8ac4f4e86 100644
--- a/recipes/eglibc/eglibc-package.bbclass
+++ b/recipes/eglibc/eglibc-package.bbclass
@@ -89,9 +89,6 @@ do_install() {
mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED
done
rm -f ${D}/etc/rpc
- rm -f ${D}${includedir}/scsi/sg.h
- rm -f ${D}${includedir}/scsi/scsi_ioctl.h
- rm -f ${D}${includedir}/scsi/scsi.h
}
TMP_LOCALE="/tmp/locale${libdir}/locale"
diff --git a/recipes/eglibc/eglibc.inc b/recipes/eglibc/eglibc.inc
index 97a45ac8dc..7863aacc89 100644
--- a/recipes/eglibc/eglibc.inc
+++ b/recipes/eglibc/eglibc.inc
@@ -3,6 +3,7 @@ HOMEPAGE = "http://www.eglibc.org/home"
SECTION = "libs"
PRIORITY = "required"
LICENSE = "LGPL"
+INC_PR = "r4"
# nptl needs unwind support in gcc, which can't be built without glibc.
DEPENDS = "virtual/${TARGET_PREFIX}gcc-intermediate linux-libc-headers"
#this leads to circular deps, so lets not add it yet
diff --git a/recipes/eglibc/eglibc_2.9.bb b/recipes/eglibc/eglibc_2.9.bb
index ecd21de6fe..b3786d3c1d 100644
--- a/recipes/eglibc/eglibc_2.9.bb
+++ b/recipes/eglibc/eglibc_2.9.bb
@@ -4,7 +4,7 @@ DEPENDS += "gperf-native"
DEFAULT_PREFERENCE = "1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/eglibc-svn"
PV = "2.9"
-PR = "r4"
+PR = "${INC_PR}.1"
SVN_REV="7430"
EGLIBC_BRANCH="eglibc-2_9"
SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_9;rev=${SVN_REV};proto=svn \
diff --git a/recipes/eglibc/eglibc_svn.bb b/recipes/eglibc/eglibc_svn.bb
index a2d3e872f9..4202a7d5e5 100644
--- a/recipes/eglibc/eglibc_svn.bb
+++ b/recipes/eglibc/eglibc_svn.bb
@@ -5,7 +5,7 @@ SRCREV = "7542"
# DEFAULT_PREFERENCE = "-1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/eglibc-svn"
PV = "2.9+svnr${SRCREV}"
-PR = "r3"
+PR = "${INC_PR}.1"
EGLIBC_BRANCH="trunk"
SRC_URI = "svn://svn.eglibc.org;module=trunk \
file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \