aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-28 09:12:14 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-28 18:58:37 +0200
commit3908084687b3060455208035b5725fee554be99e (patch)
tree5d0461a43b19329847bcf4650e26636c2bb0739e /recipes/ekiga
parentd1a1aa3c3fe2b65faec879ce216c7c61bae88076 (diff)
downloadopenembedded-3908084687b3060455208035b5725fee554be99e.tar.gz
opal: add 3.6.6
Diffstat (limited to 'recipes/ekiga')
-rw-r--r--recipes/ekiga/opal_3.6.6.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/ekiga/opal_3.6.6.bb b/recipes/ekiga/opal_3.6.6.bb
new file mode 100644
index 0000000000..502c344b13
--- /dev/null
+++ b/recipes/ekiga/opal_3.6.6.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
+ file://configure.diff;patch=1 \
+ "
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
+