aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/elfutils/elfutils_0.143.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-03 17:35:29 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-04 10:12:24 +0100
commit3aaa12394e7867816c0fe344704319cbc51d4199 (patch)
treea8da9ee54f4b8202b37c3dff1ac48092806d33b8 /recipes/elfutils/elfutils_0.143.bb
parent7e384693bd5c3069cf189a6e50ef42e5cbea3b61 (diff)
downloadopenembedded-3aaa12394e7867816c0fe344704319cbc51d4199.tar.gz
elfutils: add 0.143
Diffstat (limited to 'recipes/elfutils/elfutils_0.143.bb')
-rw-r--r--recipes/elfutils/elfutils_0.143.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/elfutils/elfutils_0.143.bb b/recipes/elfutils/elfutils_0.143.bb
new file mode 100644
index 0000000000..0827b6f971
--- /dev/null
+++ b/recipes/elfutils/elfutils_0.143.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects."
+SECTION = "base"
+LICENSE = "OSL"
+DEPENDS = "libtool"
+
+inherit autotools
+
+SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2 \
+ http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.143-1.diff.gz;patch=1 \
+ file://i386_dis.h \
+ file://x86_64_dis.h \
+"
+
+# The buildsystem wants to generate 2 .h files from source using a binary it just built, let's work around that
+
+do_configure_prepend() {
+ sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am
+
+ cp ${WORKDIR}/*dis.h ${S}/libcpu
+}
+
+