aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/emacs/emacs.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-10 10:07:23 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-10 16:43:43 +0200
commitbf9d1fad96f63095b960b8fbcd216a333be54ebe (patch)
tree61ae4157d3be324620081981f3f5283b93c81103 /recipes/emacs/emacs.inc
parent671e6901f26b1db28ee35dc4102841f9ab87ecdb (diff)
downloadopenembedded-bf9d1fad96f63095b960b8fbcd216a333be54ebe.tar.gz
emacs: add missing chunk in use-qemu.patch for 23.1, create libc.so -> libc.so.6 link
* prefix-args were built with target compiler but later executed in host environment, older emacs versions used prefix-args from qemu, but this part was missing in emacs23.1-use-qemu.patch * Paul Fertser suggested that prefix-args should be built with host compiler instead and then without need to use qemu-arm * When there is no libc.so in ${STAGING_DIR_TARGET}, which is copied to treedir, then it tries to use libc.so from host, which is wrong. Added something like angstrom-libc-fixup-hack.bb but for treedir. * Also add dbus to DEPENDS to make sure configure finds it for bindings. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/emacs/emacs.inc')
-rw-r--r--recipes/emacs/emacs.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes/emacs/emacs.inc b/recipes/emacs/emacs.inc
index d643d31624..6645f410e6 100644
--- a/recipes/emacs/emacs.inc
+++ b/recipes/emacs/emacs.inc
@@ -50,6 +50,11 @@ do_compile_prepend() {
if [ -f ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so.* ]; then
cp -pPR ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so.* $treedir/lib
fi
+ # stupid hack, but without it, it tries to use /usr/lib/libc.so from host and fails
+ # temacs: error while loading shared libraries: /usr/lib/libc.so: ELF file version does not match current one
+ if [ ! -f $treedir/lib/libc.so ]; then
+ ln -s libc.so.6 $treedir/lib/libc.so
+ fi
}
EXTRA_OEMAKE += 'QEMU="${QEMU}"'