aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enna
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-04-03 01:03:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-07 10:53:13 +0200
commiteca9a25c75c4f988fce03647083f1a625fe251f7 (patch)
tree6697389bcde6d4566a4cfea6a7341c2e090c56a4 /recipes/enna
parent2e4e91e5dde6ac25a14afc9a26a5de1f0cf7a5f6 (diff)
downloadopenembedded-eca9a25c75c4f988fce03647083f1a625fe251f7.tar.gz
enna: Move to own recipe folder and update to new Enna hg repository.
1. Create `enna.inc`. 2. Use `INC_PR`. 3. Move to new repository location. 4. Update license to LGPLv2.1+. 5. Build tested with GCC 4.4.3 and Binutils 2.20.1 for `MACHINE = "beagleboard". 6. Build tested with GCC 4.3.3 and Binuitls 2.18.50 for `MACHINE = "beagleboard". 7. Remove `dbus` from `DEPEND` since `edbus` already depends an it. 8. `libmusicbrainz`, `lightmediascanner` and `taglib` are not needed anymore as `DEPENDS`. 9. `do_configure_prepend()` fixes [1]. Thanks Koen. 10. libvalhalla 2.0.0 (`libvalhalla_hg.bb`) is needed for this version. [1] http://lists.linuxtogo.org/pipermail/openembedded-devel/2010-March/018800.html Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/enna')
-rw-r--r--recipes/enna/enna.inc16
-rw-r--r--recipes/enna/enna_hg.bb9
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes/enna/enna.inc b/recipes/enna/enna.inc
new file mode 100644
index 0000000000..4cc5b481cc
--- /dev/null
+++ b/recipes/enna/enna.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Enna is a media center application based on EFL."
+HOMEPAGE = "http://${PN}.geexbox.org/"
+SECTION = "x11/multimedia"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "curl eet evas edje ecore edbus elementary emotion"
+DEPENDS += "libxml2 libvalhalla libplayer"
+
+INC_PR = "r1"
+
+SRC_URI = "http://${PN}.geexbox.org/releases/${P}.tar.bz2;name=${PN}"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ autopoint || touch config.rpath
+}
diff --git a/recipes/enna/enna_hg.bb b/recipes/enna/enna_hg.bb
new file mode 100644
index 0000000000..89fa12b488
--- /dev/null
+++ b/recipes/enna/enna_hg.bb
@@ -0,0 +1,9 @@
+require enna.inc
+PV = "0.4.0+hg"
+PR = "${INC_PR}.0"
+
+SRCREV = "2a9c5f249b47"
+
+SRC_URI = "hg://hg.geexbox.org;proto=http;module=${PN};rev=${SRCREV}"
+
+S = "${WORKDIR}/${PN}"