aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/expat/expat_2.0.1.bb
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-04 22:06:37 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-04 22:11:32 +0100
commit78c7106f99efcbabc9ccc00343c87a900644cda3 (patch)
treeef600d625256794da273a8563817cc90308a5ded /recipes/expat/expat_2.0.1.bb
parentc512d0fcf434dd74c1fc6fc7752da829453edd7f (diff)
downloadopenembedded-78c7106f99efcbabc9ccc00343c87a900644cda3.tar.gz
expat-2.0.0: Upgrade expat library to fix various known security bugs
* Fixes CVE-2009-3720
Diffstat (limited to 'recipes/expat/expat_2.0.1.bb')
-rw-r--r--recipes/expat/expat_2.0.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/expat/expat_2.0.1.bb b/recipes/expat/expat_2.0.1.bb
new file mode 100644
index 0000000000..41739e8889
--- /dev/null
+++ b/recipes/expat/expat_2.0.1.bb
@@ -0,0 +1,29 @@
+require expat.inc
+PR = "r2"
+
+SRC_URI += "file://autotools.patch;patch=1"
+SRC_URI[src.md5sum] = "ee8b492592568805593f81f8cdf2a04c"
+SRC_URI[src.sha256sum] = "847660b4df86e707c9150e33cd8c25bc5cd828f708c7418e765e3e983a2e5e93"
+
+inherit lib_package
+
+do_configure() {
+ rm -f ${S}/conftools/libtool.m4
+ touch ${S}/conftools/libtool.m4
+ autotools_do_configure
+}
+
+do_stage() {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/lib/expat_external.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ man1dir="${D}${mandir}/man1" \
+ install
+}