aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ezx/ezx-boot-usb-native_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ezx/ezx-boot-usb-native_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ezx/ezx-boot-usb-native_svn.bb')
-rw-r--r--recipes/ezx/ezx-boot-usb-native_svn.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/ezx/ezx-boot-usb-native_svn.bb b/recipes/ezx/ezx-boot-usb-native_svn.bb
new file mode 100644
index 0000000000..426ad4a555
--- /dev/null
+++ b/recipes/ezx/ezx-boot-usb-native_svn.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Boot a Motorola EZX device with a user supplied kernel"
+DEPENDS = "libusb-native virtual/kernel"
+SECTION = "devel"
+AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
+LICENSE = "GPL"
+PV = "0.3.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
+S = "${WORKDIR}/boot_usb"
+
+EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
+
+inherit autotools native
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile