aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ezx
diff options
context:
space:
mode:
authorAntonio Ospite <ospite@studenti.unina.it>2010-03-25 07:19:55 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2010-03-26 21:15:27 +0100
commitb7436506cac5c9fcd315ea0fca297fa1ff5efd71 (patch)
tree1e655a25f10fd9b8ae5b2d30ab13d0843e383b26 /recipes/ezx
parentd372db8d95aa62f924b892cb135ffa57c4ce7640 (diff)
downloadopenembedded-b7436506cac5c9fcd315ea0fca297fa1ff5efd71.tar.gz
ezx: update ezxd version and ezxd.init script
Newer kernels have drivers for BP interaction built as modules, add the loading sequence in ezxd.init. Fix also the recipe so that the CC and CROSS variables do not interfere with the crosscompiler from OE. Signed-off-by: Antonio Ospite <ospite@studenti.unina.it> Acked-by: Stefan Schmidt <stefan@datenfreihafen.org>
Diffstat (limited to 'recipes/ezx')
-rw-r--r--recipes/ezx/ezxd/ezxd.init5
-rw-r--r--recipes/ezx/ezxd_svn.bb4
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes/ezx/ezxd/ezxd.init b/recipes/ezx/ezxd/ezxd.init
index a345952d1e..ba44942829 100644
--- a/recipes/ezx/ezxd/ezxd.init
+++ b/recipes/ezx/ezxd/ezxd.init
@@ -37,6 +37,11 @@ start_it_up()
fi
echo -n "Starting $DESC: "
+ modprobe ohci-hcd
+ sleep 2
+ modprobe moto-usb-ipc
+ modprobe ts27010mux
+
start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
--exec $DAEMON -- --system $PARAMS
# We need to sleep here because opening the mux devices takes some time
diff --git a/recipes/ezx/ezxd_svn.bb b/recipes/ezx/ezxd_svn.bb
index 134980f4c0..19bbd93184 100644
--- a/recipes/ezx/ezxd_svn.bb
+++ b/recipes/ezx/ezxd_svn.bb
@@ -22,7 +22,9 @@ CFLAGS_append = " -DDEBUG "
TARGET_CC_ARCH += "${LDFLAGS}"
do_configure() {
- sed -i -e s:CROSS:CC:g Makefile
+ # Comment out both CC and CROSS definitions
+ sed -i -e 's:^CC.*$:#\0:g' Makefile
+ sed -i -e 's:^CROSS.*$:#\0:g' Makefile
}
fakeroot do_install() {