summaryrefslogtreecommitdiffstats
path: root/recipes/fakechroot
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-08-28 07:35:22 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-03-19 20:22:35 +0100
commit62c99dac4a0b54c8030f9e1576e6f946763459f5 (patch)
treee2e3e5e64d624a8aa338e2747967a612e168e177 /recipes/fakechroot
parent7732204f1e737b5874629ea1469e69ee5db8b0a3 (diff)
downloadopenembedded-62c99dac4a0b54c8030f9e1576e6f946763459f5.tar.gz
fakechroot: fix duplicated readlink (from Poky)
git-svn-id: https://svn.o-hand.com/repos/poky@5115 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'recipes/fakechroot')
-rw-r--r--recipes/fakechroot/fakechroot-native_2.5.bb2
-rw-r--r--recipes/fakechroot/fakechroot_2.5.bb3
-rw-r--r--recipes/fakechroot/files/fix-readlink.patch32
3 files changed, 35 insertions, 2 deletions
diff --git a/recipes/fakechroot/fakechroot-native_2.5.bb b/recipes/fakechroot/fakechroot-native_2.5.bb
index efd41c7126..8cb88bdaae 100644
--- a/recipes/fakechroot/fakechroot-native_2.5.bb
+++ b/recipes/fakechroot/fakechroot-native_2.5.bb
@@ -1,5 +1,5 @@
SECTION = "base"
-PR = "r0"
+PR = "r1"
require fakechroot_${PV}.bb
inherit native
diff --git a/recipes/fakechroot/fakechroot_2.5.bb b/recipes/fakechroot/fakechroot_2.5.bb
index c791512185..dfe90779bd 100644
--- a/recipes/fakechroot/fakechroot_2.5.bb
+++ b/recipes/fakechroot/fakechroot_2.5.bb
@@ -2,6 +2,7 @@ SECTION = "base"
DESCRIPTION = "Gives a fake root environment which can support chroot"
LICENSE = "GPL"
-SRC_URI = "${DEBIAN_MIRROR}/main/f/fakechroot/fakechroot_${PV}.orig.tar.gz"
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakechroot/fakechroot_${PV}.orig.tar.gz \
+ file://fix-readlink.patch;patch=1"
inherit autotools
diff --git a/recipes/fakechroot/files/fix-readlink.patch b/recipes/fakechroot/files/fix-readlink.patch
new file mode 100644
index 0000000000..f218956790
--- /dev/null
+++ b/recipes/fakechroot/files/fix-readlink.patch
@@ -0,0 +1,32 @@
+---
+ src/libfakechroot.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- fakechroot-2.5.orig/src/libfakechroot.c
++++ fakechroot-2.5/src/libfakechroot.c
+@@ -596,11 +596,11 @@ void fakechroot_init (void)
+ nextsym(open64, "open64");
+ #if !defined(HAVE___OPENDIR2)
+ nextsym(opendir, "opendir");
+ #endif
+ nextsym(pathconf, "pathconf");
+- nextsym(readlink, "readlink");
++ nextsym(readlink, "own_readlink");
+ nextsym(realpath, "realpath");
+ nextsym(remove, "remove");
+ #ifdef HAVE_REMOVEXATTR
+ nextsym(removexattr, "removexattr");
+ #endif
+@@ -1864,11 +1864,11 @@ long pathconf (const char *path, int nam
+ return next_pathconf(path, name);
+ }
+
+
+ /* #include <unistd.h> */
+-int readlink (const char *path, char *buf, READLINK_TYPE_ARG3)
++int own_readlink (const char *path, char *buf, READLINK_TYPE_ARG3)
+ {
+ int status;
+ char tmp[FAKECHROOT_MAXPATH], *tmpptr;
+ char *fakechroot_path, *fakechroot_ptr, fakechroot_buf[FAKECHROOT_MAXPATH];
+