aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fakeroot/fakeroot-native_1.12.4.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-07-24 23:26:11 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-07-24 23:26:26 -0300
commitabff80542b61ce453ee4ba8ba010fba87b463537 (patch)
tree51a7cb4bd5491e2e7f597a4c649ba475a66083c7 /recipes/fakeroot/fakeroot-native_1.12.4.bb
parent7772c8ef529d0fff5fb439677d95d3d33c5225db (diff)
downloadopenembedded-abff80542b61ce453ee4ba8ba010fba87b463537.tar.gz
fakeroot: update to fakeroot 1.12.4 (1.12.1 is not available anymore)
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/fakeroot/fakeroot-native_1.12.4.bb')
-rw-r--r--recipes/fakeroot/fakeroot-native_1.12.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/fakeroot/fakeroot-native_1.12.4.bb b/recipes/fakeroot/fakeroot-native_1.12.4.bb
new file mode 100644
index 0000000000..5215dc86ed
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-native_1.12.4.bb
@@ -0,0 +1,20 @@
+require fakeroot_${PV}.bb
+
+SRC_URI += "file://fix-prefix.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "--program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
+RDEPENDS = "util-linux-native"