aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/farsight
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/farsight
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/farsight')
-rw-r--r--recipes/farsight/farsight_0.1.5.bb30
-rw-r--r--recipes/farsight/gst-plugins-farsight_0.10.1.bb28
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes/farsight/farsight_0.1.5.bb b/recipes/farsight/farsight_0.1.5.bb
new file mode 100644
index 0000000000..474eed9c9c
--- /dev/null
+++ b/recipes/farsight/farsight_0.1.5.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE = "http://farsight.sf.net"
+SRC_URI = "http://telepathy.freedesktop.org/releases/farsight/${P}.tar.gz"
+
+
+DEPENDS = "glib-2.0 libxml2 zlib dbus libjingle gstreamer gst-plugins-base"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " \
+--disable-debug \
+ --disable-gtk-doc \
+ --disable-sequence-diagrams \
+ --disable-sofia-sip \
+ --enable-jingle-p2p \
+ --disable-gnet \
+ --disable-msnwebcam \
+ --disable-msnavconf \
+ --disable-yahoowebcam \
+ --enable-rtp"
+
+FILES_${PN} += "${libdir}/farsight-0.1/*so"
+FILES_${PN}-dev += "${libdir}/farsight-0.1/*.a ${libdir}/farsight-0.1/*.so.*"
+
+do_stage() {
+autotools_stage_all
+}
+
+
+
diff --git a/recipes/farsight/gst-plugins-farsight_0.10.1.bb b/recipes/farsight/gst-plugins-farsight_0.10.1.bb
new file mode 100644
index 0000000000..09268b33a7
--- /dev/null
+++ b/recipes/farsight/gst-plugins-farsight_0.10.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE = "http://farsight.sf.net"
+SRC_URI = "http://telepathy.freedesktop.org/releases/gst-plugins-farsight/${P}.tar.gz"
+
+
+DEPENDS = "glib-2.0 libxml2 zlib dbus libjingle gstreamer gst-plugins-base"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " \
+--disable-debug \
+ --disable-jrtplib \
+ --disable-mimic \
+ --disable-gsm \
+ --disable-jasper \
+ --enable-jingle-p2p \
+ --with-plugins=rtpdemux,rtpjitterbuffer"
+
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*so"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.a ${libdir}/gstreamer-0.10/*.so.*"
+
+do_stage() {
+autotools_stage_all
+}
+
+
+