aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fget
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fget
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fget')
-rw-r--r--recipes/fget/fget_1.3.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/fget/fget_1.3.3.bb b/recipes/fget/fget_1.3.3.bb
new file mode 100644
index 0000000000..165167e6dc
--- /dev/null
+++ b/recipes/fget/fget_1.3.3.bb
@@ -0,0 +1,22 @@
+LICENSE = "BSD"
+DESCRIPTION = "fget is a commandline tool for mirroring \
+remote files via FTP. It was designed as an analog to the \
+GNU wget utility. The fget package includes an FTP client \
+library, so that others can make use of FTP from within \
+their own C programs."
+SECTION = "libs"
+PRIORITY = "optional"
+
+SRC_URI = "ftp://ftp.feep.net/pub/software/fget/fget-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -a -C lib libfget ${STAGING_LIBDIR}
+ install -m 0755 lib/libfget.h ${STAGING_INCDIR}/
+}
+