aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fmtools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fmtools
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fmtools')
-rw-r--r--recipes/fmtools/files/makefile.patch11
-rw-r--r--recipes/fmtools/fmtools_1.0.2.bb15
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/fmtools/files/makefile.patch b/recipes/fmtools/files/makefile.patch
new file mode 100644
index 0000000000..41c0086b82
--- /dev/null
+++ b/recipes/fmtools/files/makefile.patch
@@ -0,0 +1,11 @@
+--- fmtools-1.0.2/Makefile 2002-08-17 06:05:09.000000000 +0200
++++ fmtools-1.0.2p/Makefile 2007-12-22 21:45:28.000000000 +0100
+@@ -1,8 +1,5 @@
+ # fmtools Makefile - just the basics for now
+
+-CC = gcc
+-CFLAGS = -Wall -O2
+-
+ INSTALL = /usr/bin/install
+
+ # Since fmtools doesn't use configure, these paths are provided here
diff --git a/recipes/fmtools/fmtools_1.0.2.bb b/recipes/fmtools/fmtools_1.0.2.bb
new file mode 100644
index 0000000000..a1f9fb0f39
--- /dev/null
+++ b/recipes/fmtools/fmtools_1.0.2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "fmtools - programs for Video for Linux radio cards"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.stanford.edu/~blp/fmtools/fmtools-1.0.2.tar.gz \
+ file://makefile.patch;patch=1"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/fm ${D}${bindir}/fm
+ install -m 0755 ${S}/fmscan ${D}${bindir}/fmscan
+}
+