aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/free42
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/free42
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/free42')
-rw-r--r--recipes/free42/files/free42-bcd-gtk-only.patch100
-rw-r--r--recipes/free42/files/free42-dont-declare-sincos.patch11
-rw-r--r--recipes/free42/files/free42-vga-skin.patch12
-rw-r--r--recipes/free42/files/free42dec.desktop12
-rw-r--r--recipes/free42/free42-vga_1.4.41.bb44
5 files changed, 179 insertions, 0 deletions
diff --git a/recipes/free42/files/free42-bcd-gtk-only.patch b/recipes/free42/files/free42-bcd-gtk-only.patch
new file mode 100644
index 0000000000..571785f36f
--- /dev/null
+++ b/recipes/free42/files/free42-bcd-gtk-only.patch
@@ -0,0 +1,100 @@
+--- free42-orig/gtk/Makefile 2007-01-06 09:37:55.000000000 -0800
++++ free42gtk/gtk/Makefile 2007-09-02 23:54:34.000000000 -0700
+@@ -35,20 +35,14 @@
+ core_math2.o core_phloat.o core_sto_rcl.o core_tables.o \
+ core_variables.o
+
+-ifdef BCD_MATH
+ CXXFLAGS += -DBCD_MATH
+ SRCS += bcdfloat.cc bcd.cc bcdmath.cc
+ OBJS += bcdfloat.o bcd.o bcdmath.o
+ EXE = free42dec
+-else
+-EXE = free42bin
+-endif
+
+ $(EXE): $(OBJS)
+ $(CXX) -o $(EXE) $(LDFLAGS) $(OBJS) $(LIBS)
+
+-$(SRCS): symlinks
+-
+ .cc.o:
+ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+@@ -64,74 +58,18 @@
+ keymap.cc: keymap2cc keymap.txt
+ ./keymap2cc
+
+-symlinks:
+- ln -s ../common/free42.h
+- ln -s ../common/core_commands1.cc
+- ln -s ../common/core_commands1.h
+- ln -s ../common/core_commands2.cc
+- ln -s ../common/core_commands2.h
+- ln -s ../common/core_commands3.cc
+- ln -s ../common/core_commands3.h
+- ln -s ../common/core_commands4.cc
+- ln -s ../common/core_commands4.h
+- ln -s ../common/core_commands5.cc
+- ln -s ../common/core_commands5.h
+- ln -s ../common/core_commands6.cc
+- ln -s ../common/core_commands6.h
+- ln -s ../common/core_display.cc
+- ln -s ../common/core_display.h
+- ln -s ../common/core_globals.cc
+- ln -s ../common/core_globals.h
+- ln -s ../common/core_helpers.cc
+- ln -s ../common/core_helpers.h
+- ln -s ../common/core_keydown.cc
+- ln -s ../common/core_keydown.h
+- ln -s ../common/core_linalg1.cc
+- ln -s ../common/core_linalg1.h
+- ln -s ../common/core_linalg2.cc
+- ln -s ../common/core_linalg2.h
+- ln -s ../common/core_math1.cc
+- ln -s ../common/core_math1.h
+- ln -s ../common/core_math2.cc
+- ln -s ../common/core_math2.h
+- ln -s ../common/core_main.cc
+- ln -s ../common/core_main.h
+- ln -s ../common/core_phloat.cc
+- ln -s ../common/core_phloat.h
+- ln -s ../common/core_sto_rcl.cc
+- ln -s ../common/core_sto_rcl.h
+- ln -s ../common/core_tables.cc
+- ln -s ../common/core_tables.h
+- ln -s ../common/core_variables.cc
+- ln -s ../common/core_variables.h
+- ln -s ../common/shell.h
+- ln -s ../common/shell_loadimage.cc
+- ln -s ../common/shell_loadimage.h
+- ln -s ../common/shell_spool.cc
+- ln -s ../common/shell_spool.h
+- ln -s ../common/skin2cc.cc
+- ln -s ../common/skin2cc.conf
+- ln -s ../common/keymap2cc.cc
+- ln -s ../common/bcd.cc
+- ln -s ../common/bcd.h
+- ln -s ../common/bcdfloat.cc
+- ln -s ../common/bcdfloat.h
+- ln -s ../common/bcdmath.cc
+- ln -s ../common/bcdmath.h
+- touch symlinks
+-
+ clean: FORCE
+ rm -f `find . -type l` \
+ skin2cc skin2cc.exe skins.cc \
+ keymap2cc keymap2cc.exe keymap.cc \
+- *.o *.d *.i *.ii *.s symlinks core.*
++ *.o *.d *.i *.ii *.s core.*
+
+ cleaner: FORCE
+ rm -f `find . -type l` \
+ free42bin free42bin.exe free42dec free42dec.exe \
+ skin2cc skin2cc.exe skins.cc \
+ keymap2cc keymap2cc.exe keymap.cc \
+- *.o *.d *.i *.ii *.s symlinks core.*
++ *.o *.d *.i *.ii *.s core.*
+
+ FORCE:
+
diff --git a/recipes/free42/files/free42-dont-declare-sincos.patch b/recipes/free42/files/free42-dont-declare-sincos.patch
new file mode 100644
index 0000000000..8ba10face4
--- /dev/null
+++ b/recipes/free42/files/free42-dont-declare-sincos.patch
@@ -0,0 +1,11 @@
+--- free42-orig/common/free42.h 2007-01-06 09:37:50.000000000 -0800
++++ free42gtk/common/free42.h 2007-09-03 22:39:14.000000000 -0700
+@@ -150,7 +150,7 @@
+ * provided by MathLib.
+ */
+ #ifndef PALMOS
+-extern "C" void sincos(double x, double *sinx, double *cosx) HELPERS_SECT;
++
+ #endif
+ //#define NO_SINCOS 1
+
diff --git a/recipes/free42/files/free42-vga-skin.patch b/recipes/free42/files/free42-vga-skin.patch
new file mode 100644
index 0000000000..628a233514
--- /dev/null
+++ b/recipes/free42/files/free42-vga-skin.patch
@@ -0,0 +1,12 @@
+--- free42-orig/common/skin2cc.conf 2006-03-22 11:33:35.000000000 -0800
++++ free42gtk/common/skin2cc.conf 2007-09-02 23:52:27.000000000 -0700
+@@ -1,4 +1,4 @@
+-skins/Standard
+-Standard
+-skins/Ehrling42sl
+-Realistic
++skins/Ehrling42ssv
++Portrait
++skins/42ct
++Landscape
+
diff --git a/recipes/free42/files/free42dec.desktop b/recipes/free42/files/free42dec.desktop
new file mode 100644
index 0000000000..4d08c453ab
--- /dev/null
+++ b/recipes/free42/files/free42dec.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Free42
+Comment=RPN Calculator
+Exec=free42dec
+Icon=free42.xpm
+StartupNotify=true
+SingleInstance=true
+Terminal=false
+Type=Application
+Categories=Application
diff --git a/recipes/free42/free42-vga_1.4.41.bb b/recipes/free42/free42-vga_1.4.41.bb
new file mode 100644
index 0000000000..ff5e07feae
--- /dev/null
+++ b/recipes/free42/free42-vga_1.4.41.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Free42 RPN Calculator"
+HOMEPAGE = "http://free42.sf.net"
+SECTION = "openmoko/applications"
+DEPENDS = "gtk+"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/free42/free42.tgz \
+ http://sense.net/zc/free42/42c_skins.tgz \
+ file://free42-bcd-gtk-only.patch;patch=1 \
+ file://free42-vga-skin.patch;patch=1 \
+ file://free42-dont-declare-sincos.patch;patch=1 \
+ file://free42dec.desktop"
+
+S = "${WORKDIR}/free42"
+
+TARGET_CXXFLAGS_append = " -fsigned-char"
+TARGET_CXXFLAGS_append += "-DVERSION=\\"${PV}\\" -DBCD_MATH"
+TARGET_CXXFLAGS_append += "-I${STAGING_INCDIR}/gtk-2.0"
+TARGET_CXXFLAGS_append += "-I${STAGING_LIBDIR}/gtk-2.0/include"
+TARGET_CXXFLAGS_append += "-I${STAGING_INCDIR}/cairo"
+TARGET_CXXFLAGS_append += "-I${STAGING_INCDIR}/glib-2.0"
+TARGET_CXXFLAGS_append += "-I${STAGING_INCDIR}/pango-1.0"
+TARGET_CXXFLAGS_append += "-I${STAGING_INCDIR}/atk-1.0"
+
+do_compile() {
+ cp -fv ${S}/common/* ${S}/gtk
+ cp -fv ${S}/ppcskins/Ehrling42ssv.* ${S}/skins/
+ cp ${WORKDIR}/42ct.* ${S}/skins/
+ cd ${S}/gtk/
+ ${BUILD_CXX} -o skin2cc skin2cc.cc ${BUILD_CXXFLAGS}
+ ${BUILD_CXX} -o keymap2cc keymap2cc.cc ${BUILD_CXXFLAGS}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/gtk/free42dec ${D}${bindir}/free42dec
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/free42dec.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 ${S}/gtk/icon.xpm ${D}${datadir}/pixmaps/free42.xpm
+}
+
+