aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freescale
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmx.de>2011-05-03 22:40:48 +0000
committerEric Bénard <eric@eukrea.com>2011-05-14 15:33:00 +0200
commita324fe7b35deac983015ad0a2ca63a5dcbdb4681 (patch)
treec7da8e4b144e61bf628015cf25a5ec0bc17bd182 /recipes/freescale
parenteb286fe259ae63507e25502d4e387ce2d03cd687 (diff)
downloadopenembedded-a324fe7b35deac983015ad0a2ca63a5dcbdb4681.tar.gz
elftosb: Add native helper to create boot stream files used by freescale iMX SoCs
Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/freescale')
-rw-r--r--recipes/freescale/elftosb/uclibc_and_eglibc_have_no_powf.patch12
-rw-r--r--recipes/freescale/elftosb_10.12.01.bb20
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes/freescale/elftosb/uclibc_and_eglibc_have_no_powf.patch b/recipes/freescale/elftosb/uclibc_and_eglibc_have_no_powf.patch
new file mode 100644
index 0000000000..78740230bf
--- /dev/null
+++ b/recipes/freescale/elftosb/uclibc_and_eglibc_have_no_powf.patch
@@ -0,0 +1,12 @@
+--- a/elftosb2/ElftosbAST.cpp.old 2010-09-20 15:28:03.000000000 +0200
++++ b/elftosb2/ElftosbAST.cpp 2011-04-18 22:25:54.000000000 +0200
+@@ -755,7 +755,8 @@
+ #ifdef WIN32
+ result = 0;
+ #else
+- result = lroundf(powf(float(leftValue), float(rightValue)));
++ //result = lroundf(powf(float(leftValue), float(rightValue)));
++ result = 0;
+ #endif
+ break;
+ case kBitwiseAnd:
diff --git a/recipes/freescale/elftosb_10.12.01.bb b/recipes/freescale/elftosb_10.12.01.bb
new file mode 100644
index 0000000000..9fc18a0cda
--- /dev/null
+++ b/recipes/freescale/elftosb_10.12.01.bb
@@ -0,0 +1,20 @@
+LICENSE = "FREESCALE"
+PR = "r0"
+
+SRC_URI = "http://foss.doredevelopment.dk/mirrors/imx/elftosb-${PV}.tar.gz \
+ file://uclibc_and_eglibc_have_no_powf.patch"
+
+SRC_URI[md5sum] = "e8005d606c1e0bb3507c82f6eceb3056"
+SRC_URI[sha256sum] = "77bb6981620f7575b87d136d94c7daa88dd09195959cc75fc18b138369ecd42b"
+
+BBCLASSEXTEND = "native"
+
+do_install() {
+ install -d ${D}${bindir}
+ install ${S}/bld/linux/elftosb ${D}${bindir}/
+ install ${S}/bld/linux/keygen ${D}${bindir}/
+ install ${S}/bld/linux/sbtool ${D}${bindir}/
+}
+
+NATIVE_INSTALL_WORKS = "1"
+