aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak <seba.dos1@gmail.com>2010-07-07 12:14:34 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-07-07 15:33:57 +0200
commit3c4955f19ab66503bb321f959ec6756fa2bdbe28 (patch)
tree2df48e25daf86ee1ecc8a0405198a7cc4e993800 /recipes/freesmartphone
parent934edd1e587a259882fa9fc2a53aca85a4ee667e (diff)
downloadopenembedded-3c4955f19ab66503bb321f959ec6756fa2bdbe28.tar.gz
frameworkd: add patch for SHR to workaround bug in kernel resulting in weak vibrator strength
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/frameworkd/0001-oeventsd-workaround-buggy-kernel-to-get-full-vibrati.patch33
-rw-r--r--recipes/freesmartphone/frameworkd_git.bb6
2 files changed, 37 insertions, 2 deletions
diff --git a/recipes/freesmartphone/frameworkd/0001-oeventsd-workaround-buggy-kernel-to-get-full-vibrati.patch b/recipes/freesmartphone/frameworkd/0001-oeventsd-workaround-buggy-kernel-to-get-full-vibrati.patch
new file mode 100644
index 0000000000..1dd1ef23fe
--- /dev/null
+++ b/recipes/freesmartphone/frameworkd/0001-oeventsd-workaround-buggy-kernel-to-get-full-vibrati.patch
@@ -0,0 +1,33 @@
+From 72ad63c5ce9f2d25a119612065d86bd317bf80ed Mon Sep 17 00:00:00 2001
+From: Sebastian Krzyszkowiak <seba.dos1@gmail.com>
+Date: Wed, 7 Jul 2010 15:01:59 +0200
+Subject: [PATCH] oeventsd: workaround buggy kernel to get full vibration power.
+ This patch should be disabled as soon as fixed kernel arrives.
+
+---
+ framework/subsystems/oeventsd/fso_actions.py | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/framework/subsystems/oeventsd/fso_actions.py b/framework/subsystems/oeventsd/fso_actions.py
+index c0a29dd..b9a2104 100644
+--- a/framework/subsystems/oeventsd/fso_actions.py
++++ b/framework/subsystems/oeventsd/fso_actions.py
+@@ -162,13 +162,13 @@ class VibratorAction(Action):
+ 'org.freesmartphone.odeviced',
+ '/org/freesmartphone/Device/Vibrator/%s' % self.target,
+ 'org.freesmartphone.Device.Vibrator',
+- 'VibratePattern', 999, 300, 700, 90).trigger()
++ 'VibratePattern', 999, 300, 700, 25).trigger()
+ elif self.mode == "oneshot":
+ DBusAction(dbus.SystemBus(),
+ 'org.freesmartphone.odeviced',
+ '/org/freesmartphone/Device/Vibrator/%s' % self.target,
+ 'org.freesmartphone.Device.Vibrator',
+- 'Vibrate', 400, 90).trigger()
++ 'Vibrate', 400, 25).trigger()
+ else:
+ logger.warning( "invalid vibration mode '%s', valid are 'continuous' or 'oneshot'" )
+
+--
+1.7.1
+
diff --git a/recipes/freesmartphone/frameworkd_git.bb b/recipes/freesmartphone/frameworkd_git.bb
index dea799351f..9dfb107ebe 100644
--- a/recipes/freesmartphone/frameworkd_git.bb
+++ b/recipes/freesmartphone/frameworkd_git.bb
@@ -6,7 +6,7 @@ DEPENDS = "python-cython-native python-pyrex-native"
LICENSE = "GPL"
SRCREV = "8f618948c4c74853f28b773cdc74ceefa1fb6899"
PV = "0.9.5.9+gitr${SRCPV}"
-PR = "r4"
+PR = "r5"
PE = "1"
inherit distutils update-rc.d python-dir
@@ -20,7 +20,9 @@ SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master \
file://frameworkd \
file://frameworkd.conf \
"
-SRC_URI_append_shr = "file://oeventsd-use-opimd-signals.patch"
+SRC_URI_append_shr = "file://oeventsd-use-opimd-signals.patch \
+ file://0001-oeventsd-workaround-buggy-kernel-to-get-full-vibrati.patch \
+ "
S = "${WORKDIR}/git"