summaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-26 19:32:46 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-26 19:38:55 +0200
commit451b945c526286417ae471e5f9dfce0373ff8bd0 (patch)
tree339e92874adbc558d4e1aae38adbda3e24c5dd17 /recipes/freesmartphone
parent047d4f9f0064b5e3c777b6006a61c2d4370e92c6 (diff)
downloadopenembedded-451b945c526286417ae471e5f9dfce0373ff8bd0.tar.gz
fsodeviced: add short preinst work-arround
* for opkg complaining that it cannot replace alsa-default dir (leftover from older fsodeviced) with new alsa-default symlink Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 90eb91c101..1e1f73e710 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -9,7 +9,7 @@ RPROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.0+gitr${SRCPV}"
PE = "2"
-PR = "${INC_PR}.10"
+PR = "${INC_PR}.11"
EXTRA_OECONF = "\
--enable-kernel26-rfkill \
@@ -27,3 +27,8 @@ do_install_append() {
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/fsodeviced ${D}${sysconfdir}/init.d/
}
+
+pkg_preinst_${PN} () {
+ # work-arround for opkg complaining that it cannot replace alsa-default dir (leftover from older fsodeviced) with new alsa-default symlink
+ rm -rf ${sysconfdir}/freesmartphone/conf/openmoko_gta/alsa-default/
+}