summaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-12 02:15:29 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-12 02:15:48 +0200
commit61d6b15d54b5d77e520dafee7a0ce70f3c666ed3 (patch)
tree700967ffb8885b38784a8f48dbb60309ae80bdbc /recipes/freesmartphone
parent0189e3a0d7b9137c4762ecf03345fc5303510fa0 (diff)
downloadopenembedded-61d6b15d54b5d77e520dafee7a0ce70f3c666ed3.tar.gz
zhone2: install init script
Diffstat (limited to 'recipes/freesmartphone')
-rwxr-xr-xrecipes/freesmartphone/zhone2/zhone211
-rw-r--r--recipes/freesmartphone/zhone2_git.bb22
2 files changed, 29 insertions, 4 deletions
diff --git a/recipes/freesmartphone/zhone2/zhone2 b/recipes/freesmartphone/zhone2/zhone2
new file mode 100755
index 0000000000..f868e3d248
--- /dev/null
+++ b/recipes/freesmartphone/zhone2/zhone2
@@ -0,0 +1,11 @@
+#!/bin/sh
+cat /usr/share/zhone2/splash > /dev/fb0
+ifconfig usb0 192.168.0.202 up
+route add default gateway 192.168.0.200 usb0
+fsogsmd &
+sleep 5
+#mioctl /dev/fb0 0x4611 0
+TSLIB_TSDEVICE=/dev/input/event1
+export TSLIB_TSDEVICE
+zhone2 >/tmp/zhone2.log 2>&1 &
+exit 0
diff --git a/recipes/freesmartphone/zhone2_git.bb b/recipes/freesmartphone/zhone2_git.bb
index eb19fbaeec..b29125a99b 100644
--- a/recipes/freesmartphone/zhone2_git.bb
+++ b/recipes/freesmartphone/zhone2_git.bb
@@ -1,13 +1,27 @@
-DESCRIPTION = "A demo phone application based on FSO"
+DESCRIPTION = "A demo phone application based on FSO 2.0"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "x11"
LICENSE = "GPLv2"
DEPENDS = "edje-native vala-native evas ecore edje libeflvala libfsobasics libfsoframework libfso-glib"
PV = "2.0.0+gitr${SRCREV}"
-PR = "r0"
+PR = "r2"
-SRC_URI = "${FREESMARTPHONE_GIT}/aurora.git;protocol=git;branch=master"
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/aurora.git;protocol=git;branch=master \
+ http://www.linuxtogo.org/~mickeyl/misc/splash \
+ file://zhone2 \
+"
S = "${WORKDIR}/git/zhone2"
-inherit autotools_stage
+inherit autotools_stage update-rc.d
+
+INITSCRIPT_NAME = "zhone2"
+INITSCRIPT_PARAMS = "defaults 40"
+
+do_install_append() {
+ install -d ${D}${datadir}/zhone2/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0644 ${WORKDIR}/splash ${D}${datadir}/zhone2/
+ install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
+}