summaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-01 15:50:12 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-02 21:17:10 +0200
commite0fd0683b2cec0bf449701a4baf4290587d0f809 (patch)
treeb5f69aac389e415ddc7937a9cbc195a2ad5f52c4 /recipes/freesmartphone
parent1b3d6bc94652c7ffb47ece8771cdb3a33f02a0d3 (diff)
downloadopenembedded-e0fd0683b2cec0bf449701a4baf4290587d0f809.tar.gz
fsoraw: add recipe for fsoraw rewritten in vala
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/fsoraw_git.bb18
-rw-r--r--recipes/freesmartphone/fsoraw_svn.bb6
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/freesmartphone/fsoraw_git.bb b/recipes/freesmartphone/fsoraw_git.bb
new file mode 100644
index 0000000000..d16811b03a
--- /dev/null
+++ b/recipes/freesmartphone/fsoraw_git.bb
@@ -0,0 +1,18 @@
+require cornucopia.inc
+
+DESCRIPTION = "A console wrapper for the FSO Usage API"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "fso/base"
+LICENSE = "GPLv2"
+SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
+PV = "1.0.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+PE = "1"
+
+S = "${WORKDIR}/git/tools/fso-raw"
+
+# for backward compatibility in scripts
+do_install_append() {
+ install -d ${D}${bindir}
+ ln -s fso-raw ${D}${bindir}/fsoraw
+}
diff --git a/recipes/freesmartphone/fsoraw_svn.bb b/recipes/freesmartphone/fsoraw_svn.bb
index 74b1274782..f10f2212f0 100644
--- a/recipes/freesmartphone/fsoraw_svn.bb
+++ b/recipes/freesmartphone/fsoraw_svn.bb
@@ -12,3 +12,9 @@ SRC_URI = "svn://noko.svn.sourceforge.net/svnroot/noko/trunk;module=fsoraw;proto
S = "${WORKDIR}/fsoraw/"
inherit autotools
+
+# for forward compatibility in scripts
+do_install_append() {
+ install -d ${D}${bindir}
+ ln -s fsoraw ${D}${bindir}/fso-raw
+}