summaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-01 15:08:28 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-01 21:49:59 +0200
commitf52cfb976ae1929b1956b9e45e060a5a5108cb08 (patch)
tree9c40dd0a410837d154bdb07a0141959f26c600a4 /recipes/freesmartphone
parent4a134e561aa0b19642005704111fbc0ef2b6e111 (diff)
downloadopenembedded-f52cfb976ae1929b1956b9e45e060a5a5108cb08.tar.gz
freesmartphone: create python-helpers.inc, with shared variables and SRCREV
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/mdbus_git.bb9
-rw-r--r--recipes/freesmartphone/mickeyterm_git.bb9
-rw-r--r--recipes/freesmartphone/multicat_git.bb9
-rw-r--r--recipes/freesmartphone/pycd_git.bb7
-rw-r--r--recipes/freesmartphone/python-helpers.inc8
5 files changed, 20 insertions, 22 deletions
diff --git a/recipes/freesmartphone/mdbus_git.bb b/recipes/freesmartphone/mdbus_git.bb
index f90fd7eb8c..14a676e017 100644
--- a/recipes/freesmartphone/mdbus_git.bb
+++ b/recipes/freesmartphone/mdbus_git.bb
@@ -1,16 +1,13 @@
DESCRIPTION = "Mickey's DBus introspection and calling Program"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "0.9.2+gitr${SRCPV}"
-PE = "1"
PR = "r2"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
do_install() {
install -d ${D}${bindir}
install -m 0755 mickeydbus/mdbus ${D}${bindir}
diff --git a/recipes/freesmartphone/mickeyterm_git.bb b/recipes/freesmartphone/mickeyterm_git.bb
index 20730218f1..41b5636625 100644
--- a/recipes/freesmartphone/mickeyterm_git.bb
+++ b/recipes/freesmartphone/mickeyterm_git.bb
@@ -1,16 +1,13 @@
DESCRIPTION = "Mickey's Terminal Program"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "2.9.1+gitr${SRCPV}"
-PE = "1"
PR = "r3"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
do_install() {
install -d ${D}${bindir}
install -m 0755 mickeyterm/mickeyterm ${D}${bindir}
diff --git a/recipes/freesmartphone/multicat_git.bb b/recipes/freesmartphone/multicat_git.bb
index a47f6056e0..77d61159b3 100644
--- a/recipes/freesmartphone/multicat_git.bb
+++ b/recipes/freesmartphone/multicat_git.bb
@@ -1,16 +1,13 @@
DESCRIPTION = "Multiple cat utility"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "0.0.0+gitr${SRCPV}"
-PE = "1"
PR = "r1"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
do_install() {
install -d ${D}${bindir}
install -m 0755 multicat/multicat ${D}${bindir}
diff --git a/recipes/freesmartphone/pycd_git.bb b/recipes/freesmartphone/pycd_git.bb
index 92b0bb951d..eebc11c0a0 100644
--- a/recipes/freesmartphone/pycd_git.bb
+++ b/recipes/freesmartphone/pycd_git.bb
@@ -1,14 +1,13 @@
DESCRIPTION = "Python Clone Factory"
AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "0.1+gitr${SRCPV}"
-PE = "1"
PR = "r0"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
S = "${WORKDIR}/git/${PN}"
RDEPENDS_${PN} = "\
diff --git a/recipes/freesmartphone/python-helpers.inc b/recipes/freesmartphone/python-helpers.inc
new file mode 100644
index 0000000000..4397627e6d
--- /dev/null
+++ b/recipes/freesmartphone/python-helpers.inc
@@ -0,0 +1,8 @@
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PE = "1"
+
+FSO_PYTHONHELPERS_SRCREV ?= "63b1dff1bc8ac22efabcee8a90e957c3b2423317"
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"