aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/frozen-bubble
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/frozen-bubble
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/frozen-bubble')
-rw-r--r--recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.PL.patch26
-rw-r--r--recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.patch16
-rw-r--r--recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile_top.patch13
-rw-r--r--recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.PL.patch32
-rw-r--r--recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.patch13
-rw-r--r--recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile_top.patch15
-rw-r--r--recipes/frozen-bubble/frozen-bubble-2.2.0/localespath-fix.patch11
-rw-r--r--recipes/frozen-bubble/frozen-bubble_1.0.0.bb19
-rw-r--r--recipes/frozen-bubble/frozen-bubble_2.2.0.bb79
9 files changed, 224 insertions, 0 deletions
diff --git a/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.PL.patch b/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.PL.patch
new file mode 100644
index 0000000000..5f7829f753
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.PL.patch
@@ -0,0 +1,26 @@
+--- frozen-bubble/c_stuff/Makefile.PL.old 2004-06-25 19:51:53.000000000 +0100
++++ frozen_bubble/c_stuff/Makefile.PL 2004-06-25 20:07:43.000000000 +0100
+@@ -16,8 +16,8 @@
+ }
+ EOTEST
+ close(CTEST);
+- $r = system("$Config{cc} -o $fname $fname.c $cflags $libs 2>/dev/null 1>/dev/null");
+- warn("RUNNING: $Config{cc} -o $fname $fname.c $cflags $libs\n") if $ENV{VERBOSE};
++ $r = system("$ENV{CC} $ENV{CFLAGS} $ENV{LDFLAGS} -o $fname $fname.c $cflags $libs 2>/dev/null 1>/dev/null");
++ warn("RUNNING: $ENV{CC} $ENV{CFLAGS} $ENV{LDFLAGS} -o $fname $fname.c $cflags $libs\n") if $ENV{VERBOSE};
+ unlink($fname, "$fname.c");
+ return $r == 0;
+ }
+@@ -51,10 +51,10 @@
+
+ WriteMakefile(
+ 'NAME' => 'fb_c_stuff',
+- 'LIBS' => [ chomp_(`sdl-config --libs`) . ' -lSDL_mixer'],
++ 'LIBS' => [ $ENV{LDFLAGS} . " " . chomp_(`sdl-config --libs`) . ' -lSDL_mixer'],
+ 'VERSION_FROM' => 'fb_c_stuff.pm', # finds VERSION
+ 'OBJECT' => 'fb_c_stuff.o',
+- 'INC' => chomp_(`sdl-config --cflags`) . ' -I.',
++ 'INC' => $ENV{CFLAGS} . " " . chomp_(`sdl-config --cflags`) . ' -I.',
+ 'OPTIMIZE' => '-O2 -Wall',
+ 'MAKEFILE' => 'Makefile_c',
+ );
diff --git a/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.patch b/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.patch
new file mode 100644
index 0000000000..60844a735b
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile.patch
@@ -0,0 +1,16 @@
+--- frozen-bubble/c_stuff/Makefile.old 2004-06-25 20:04:03.000000000 +0100
++++ frozen-bubble/c_stuff/Makefile 2004-06-25 20:07:25.000000000 +0100
+@@ -1,11 +1,11 @@
+ .PHONY: clean
+
+ fb_c_stuff: %: %.xs
+- test -e Makefile_c || perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS)
++ test -e Makefile_c || perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) CC="$(CC)" LD="$(LD)"
+ $(MAKE) -f Makefile_c
+
+ install:
+- test -e Makefile_c || perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS)
++ test -e Makefile_c || perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) CC="$(CC)" LD="$(LD)"
+ $(MAKE) -f Makefile_c install
+
+ clean:
diff --git a/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile_top.patch b/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile_top.patch
new file mode 100644
index 0000000000..60071c3944
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble-1.0.0/Makefile_top.patch
@@ -0,0 +1,13 @@
+--- frozen-bubble/Makefile.old 2005-02-24 20:55:27.000000000 +0100
++++ frozen-bubble/Makefile 2005-02-24 20:58:53.000000000 +0100
+@@ -8,8 +8,8 @@
+ all: dirs
+
+ dirs:
+- @if ! perl -e 'use SDL'; then echo -e "\n *** I need perl-SDL installed"; false; fi
+- @if ! perl -e 'use SDL; ($$mj, $$mn, $$mc) = split /\./, $$SDL::VERSION; exit 1 if $$mj<1 || $$mn<19'; then echo -e "\n *** I need perl-SDL version 1.19.0 or upper"; false; fi
++# @if ! perl -e 'use SDL'; then echo -e "\n *** I need perl-SDL installed"; false; fi
++# @if ! perl -e 'use SDL; ($$mj, $$mn, $$mc) = split /\./, $$SDL::VERSION; exit 1 if $$mj<1 || $$mn<19'; then echo -e "\n *** I need perl-SDL version 1.19.0 or upper"; false; fi
+ @for n in . $(DIRS); do \
+ [ "$$n" = "." ] || $(MAKE) -C $$n ;\
+ done
diff --git a/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.PL.patch b/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.PL.patch
new file mode 100644
index 0000000000..7b8035b65c
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.PL.patch
@@ -0,0 +1,32 @@
+Index: frozen-bubble-2.2.0/c_stuff/Makefile.PL
+===================================================================
+--- frozen-bubble-2.2.0.orig/c_stuff/Makefile.PL
++++ frozen-bubble-2.2.0/c_stuff/Makefile.PL
+@@ -16,8 +16,8 @@ $main;
+ }
+ EOTEST
+ close(CTEST);
+- $r = system("$Config{cc} -o $fname $fname.c $cflags $libs 2>/dev/null 1>/dev/null");
+- warn("RUNNING: $Config{cc} -o $fname $fname.c $cflags $libs\n") if $ENV{VERBOSE};
++ $r = system("$ENV{CC} $ENV{CFLAGS} $ENV{LDFLAGS} -o $fname $fname.c $cflags $libs 2>/dev/null 1>/dev/null");
++ warn("RUNNING: $ENV{CC} $ENV{CFLAGS} $ENV{LDFLAGS} -o $fname $fname.c $cflags $libs\n") if $ENV{VERBOSE};
+ unlink($fname, "$fname.c");
+ return $r == 0;
+ }
+@@ -70,13 +70,13 @@ ccompile('#include <SDL_Pango.h>',
+ die_ 'Frozen-Bubble patches are needed in SDL_Pango (impossible to create an executable calling the function SDLPango_CreateContext_GivenFontDesc)';
+
+
+-
++
+ WriteMakefile(
+ 'NAME' => 'fb_c_stuff',
+- 'LIBS' => [ '-lm ' . chomp_(`sdl-config --libs`) . ' -lSDL_mixer ' . chomp_(`pkg-config SDL_Pango --libs`)],
++ 'LIBS' => [ $ENV{LDFLAGS} . " " . '-lm ' . chomp_(`sdl-config --libs`) . ' -lSDL_mixer ' . chomp_(`pkg-config SDL_Pango --libs`)],
+ 'VERSION_FROM' => 'fb_c_stuff.pm', # finds VERSION
+ 'OBJECT' => 'fb_c_stuff.o',
+- 'INC' => chomp_(`sdl-config --cflags`) . ' ' . chomp_(`pkg-config SDL_Pango --cflags`) . ' -I.',
++ 'INC' => $ENV{CFLAGS} . " " . chomp_(`sdl-config --cflags`) . ' ' . chomp_(`pkg-config SDL_Pango --cflags`) . ' -I.',
+ 'OPTIMIZE' => '-O2 -Wall',
+ 'MAKEFILE' => 'Makefile_c',
+ );
diff --git a/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.patch b/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.patch
new file mode 100644
index 0000000000..d3a370c6ab
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile.patch
@@ -0,0 +1,13 @@
+Index: frozen-bubble-2.2.0/c_stuff/Makefile
+===================================================================
+--- frozen-bubble-2.2.0.orig/c_stuff/Makefile
++++ frozen-bubble-2.2.0/c_stuff/Makefile
+@@ -51,7 +51,7 @@ PERL_MAKE_OPTS = $(PMO_PREFIX) $(PMO_INS
+ $(PMO_INSTALLMAN1DIR) $(PMO_INSTALLMAN3DIR)
+
+ Makefile_c: Makefile.PL
+- perl Makefile.PL $(PERL_MAKE_OPTS) INSTALLDIRS=$(INSTALLDIRS)
++ perl Makefile.PL $(PERL_MAKE_OPTS) INSTALLDIRS=$(INSTALLDIRS) CC="$(CC)" LD="$(LD)"
+
+ fb_c_stuff: %: %.xs Makefile_c
+ $(MAKE) -f Makefile_c
diff --git a/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile_top.patch b/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile_top.patch
new file mode 100644
index 0000000000..2dfc4e8d8c
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble-2.2.0/Makefile_top.patch
@@ -0,0 +1,15 @@
+Index: frozen-bubble-2.2.0/Makefile
+===================================================================
+--- frozen-bubble-2.2.0.orig/Makefile
++++ frozen-bubble-2.2.0/Makefile
+@@ -14,8 +14,8 @@ prepare:
+ perl -ne "print \$$1 if m|\\\$$version = '(.*)';|" c_stuff/lib/fb_stuff.pm > VERSION
+
+ dirs:
+- @if ! perl -e 'use SDL'; then echo -e "\n *** I need perl-SDL installed"; false; fi
+- @if ! perl -e 'use SDL; ($$mj, $$mn, $$mc) = split /\./, $$SDL::VERSION; exit 0 if $$mj > 1 || $$mn >= 19; exit 1'; then echo -e "\n *** I need perl-SDL version 1.19.0 or upper"; false; fi
++# @if ! perl -e 'use SDL'; then echo -e "\n *** I need perl-SDL installed"; false; fi
++# @if ! perl -e 'use SDL; ($$mj, $$mn, $$mc) = split /\./, $$SDL::VERSION; exit 0 if $$mj > 1 || $$mn >= 19; exit 1'; then echo -e "\n *** I need perl-SDL version 1.19.0 or upper"; false; fi
+ @for n in . $(DIRS); do \
+ [ "$$n" = "." ] || $(MAKE) -C $$n || exit $$? ;\
+ done
diff --git a/recipes/frozen-bubble/frozen-bubble-2.2.0/localespath-fix.patch b/recipes/frozen-bubble/frozen-bubble-2.2.0/localespath-fix.patch
new file mode 100644
index 0000000000..c083b29886
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble-2.2.0/localespath-fix.patch
@@ -0,0 +1,11 @@
+Index: frozen-bubble-2.2.0/settings.mk
+===================================================================
+--- frozen-bubble-2.2.0.orig/settings.mk
++++ frozen-bubble-2.2.0/settings.mk
+@@ -1,4 +1,5 @@
+-PREFIX = /usr/local
++
++PREFIX = /usr
+ DATADIR = $(PREFIX)/share
+ LIBDIR = $(PREFIX)/lib
+ BINDIR = $(PREFIX)/bin
diff --git a/recipes/frozen-bubble/frozen-bubble_1.0.0.bb b/recipes/frozen-bubble/frozen-bubble_1.0.0.bb
new file mode 100644
index 0000000000..503c4c7a7d
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble_1.0.0.bb
@@ -0,0 +1,19 @@
+LICENSE = "GPL"
+SECTION = "games"
+DEPENDS = "libsdl-mixer libsdl-image sdl-perl"
+
+SRC_URI = "http://zarb.org/~gc/fb//frozen-bubble-${PV}.tar.bz2 \
+ file://Makefile_top.patch;patch=1 \
+ file://Makefile.patch;patch=1 \
+ file://Makefile.PL.patch;patch=1"
+# The Makefile needs to be patched to look in STAGING_LIBDIR/perl/... - It's looking in i686-linux/lib at the moment, regardless of arch
+BROKEN = "1"
+
+
+do_compile() {
+ oe_runmake OPTIMIZE="${CFLAGS}" PREFIX="${prefix}"
+}
+
+do_install() {
+ oe_runmake PREFIX="${D}${prefix}" install
+}
diff --git a/recipes/frozen-bubble/frozen-bubble_2.2.0.bb b/recipes/frozen-bubble/frozen-bubble_2.2.0.bb
new file mode 100644
index 0000000000..27afc64f65
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble_2.2.0.bb
@@ -0,0 +1,79 @@
+DESCRIPTION="A Puzzle Bubble clone written in perl (now with network support)"
+LICENSE = "GPL"
+SECTION = "games"
+DEPENDS = "sdlpango libsdl-mixer perl"
+RDEPENDS_${PN} = "${PN}-data perl sdl-perl \
+ perl-module-strict perl-module-vars \
+ perl-module-getopt-long perl-module-exporter-heavy \
+ perl-module-data-dumper \
+ perl-module-bytes liblocale-gettext-perl \
+ perl-module-dynaloader perl-module-posix \
+ perl-module-math-trig \
+ perl-module-io-file perl-module-io \
+ perl-module-file-spec-unix perl-module-time-hires \
+ perl-module-io-socket perl-module-io-select \
+ perl-module-file-glob \
+ "
+
+PR="r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit cpan-base
+
+S=${WORKDIR}/frozen-bubble-2.2.0/
+
+PERL_VERSION = ${@get_perl_version(d)}
+
+SRC_URI = "http://www.frozen-bubble.org/data/frozen-bubble-${PV}.tar.bz2 \
+ file://Makefile.PL.patch;patch=1 \
+ file://Makefile.patch;patch=1 \
+ file://Makefile_top.patch;patch=1 \
+ file://localespath-fix.patch;patch=1 \
+ "
+
+#permit the installation of the locales in ${datadir}/locales otherwise they are installed in /usr/local/share/locales
+
+# The Makefile needs to be patched to look in STAGING_LIBDIR/perl/... - It's looking in i686-linux/lib at the moment, regardless of arch
+BROKEN = "1"
+
+
+do_compile() {
+ oe_runmake OPTIMIZE="${CFLAGS}" PREFIX="${prefix}" INSTALLSITELIB="${D}/${libdir}/perl/${PERL_VERSION}/" LOCALEDIR="${datadir}/locale"
+}
+
+do_install() {
+ oe_runmake PREFIX="${prefix}" DESTDIR="${D}" DATADIR="${datadir}" LOCALEDIR="${datadir}/locale" install
+}
+
+PACKAGES += "${PN}-editor ${PN}-data ${PN}-server"
+
+
+DESCRIPTION_${PN}-editor = "Map Editor for Frozen Bubble"
+DESCRIPTION_${PN}-data = "Mandatory data package for Frozen Bubble"
+DESCRIPTION_${PN}-server = "Server for Frozen Bubble"
+
+FILES_${PN} = "\
+ ${bindir}/frozen-bubble \
+ ${libdir}/perl/${PERL_VERSION}/auto/fb_c_stuff/fb_c_stuff.* \
+ ${libdir}/perl/${PERL_VERSION}/fb* \
+ ${libdir}/perl/${PERL_VERSION}/perllocal.pod \
+ ${libdir}/perl/${PERL_VERSION}/FBLE.pm \
+"
+
+FILES_${PN}-dbg += " \
+ ${libdir}/perl/${PERL_VERSION}/auto/fb_c_stuff/.debug \
+ ${libdir}/${PN}/.debug \
+"
+
+FILES_${PN}-editor = "\
+ ${bindir}/frozen-bubble-editor \
+"
+
+FILES_${PN}-data = "\
+ ${datadir}/frozen-bubble \
+"
+
+FILES_${PN}-server = " \
+ ${libdir}/${PN}/fb-server \
+"