summaryrefslogtreecommitdiffstats
path: root/recipes/g15daemon
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/g15daemon
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/g15daemon')
-rw-r--r--recipes/g15daemon/g15daemon_1.2.6a.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/g15daemon/g15daemon_1.2.6a.bb b/recipes/g15daemon/g15daemon_1.2.6a.bb
new file mode 100644
index 0000000000..116d2efe84
--- /dev/null
+++ b/recipes/g15daemon/g15daemon_1.2.6a.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "G15daemon takes control of the G15 keyboard, \
+allowing the use of all keys through the linux kernel uinput \
+device driver. It also controls the use of the keyboard's \
+LCD display, allows multiple, simultaneous client applications \
+to connect, and gives the user the ability to switch between \
+client apps at the press of a button."
+HOMEPAGE = "http://g15tools.sourceforge.net"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+PRIORITY = "optional"
+DEPENDS = "libdaemon libg15"
+RDEPENDS = "libg15"
+RRECOMMENDS = "kernel-module-uinput"
+PR ="r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/g15daemon/g15daemon-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-gnu-ld"
+
+do_stage () {
+ autotools_stage_all
+}
+