summaryrefslogtreecommitdiffstats
path: root/recipes/gammu
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-23 15:20:19 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-25 09:28:26 +0300
commit658ae76b938a90ac3587909f6b8525559fe57b56 (patch)
tree9216406ea230a65552429cb71c190c0e00d04c2d /recipes/gammu
parente0f9409803d6edc14608828967c0c52b5a2d182e (diff)
downloadopenembedded-658ae76b938a90ac3587909f6b8525559fe57b56.tar.gz
use PYTHON_SITEPACKAGES_DIR
Converted most of python site-packages references to PYTHON_SITEPACKAGES_DIR. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/gammu')
-rw-r--r--recipes/gammu/gammu_1.26.1.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes/gammu/gammu_1.26.1.bb b/recipes/gammu/gammu_1.26.1.bb
index ec8ef74f24..c9f8ba8310 100644
--- a/recipes/gammu/gammu_1.26.1.bb
+++ b/recipes/gammu/gammu_1.26.1.bb
@@ -10,12 +10,10 @@ SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2"
inherit distutils-common-base cmake
-PYTHON_DIR = "${@python_dir(d)}"
-
do_configure() {
cd ${S}
sed -i 's@^cmake [^$]*\$@cmake -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_TARGET} $@' configure
- sed -i 's@\${PYTHON_SITEDIR}@${libdir}/${PYTHON_DIR}/site-packages@g' python/gammu/CMakeLists.txt
+ sed -i 's@\${PYTHON_SITEDIR}@${PYTHON_SITEPACKAGES_DIR}@g' python/gammu/CMakeLists.txt
./configure --prefix=${prefix} --enable-shared --enable-backup
}
@@ -35,7 +33,7 @@ PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu"
FILES_${PN}-smsd = "${bindir}/gammu-smsd*"
FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
-FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${libdir}/python*/site-packages/gammu/.debug"
+FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${PYTHON_SITEPACKAGES_DIR}/gammu/.debug"
FILES_libgammu = "${libdir}/libGammu.so.*"
FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
-FILES_python-${PN} = "${libdir}/${PYTHON_DIR}/site-packages/gammu/*.??"
+FILES_python-${PN} = "${PYTHON_SITEPACKAGES_DIR}/gammu/*.??"