aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/files
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-18 18:51:04 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-20 19:23:46 +0400
commit65e509aeddd26a6829ee10aa21fa20d6fd3def3e (patch)
tree472ccde0b7a45989d2769f771b879c38f9deb4d5 /recipes/gcc/files
parent69d4f160583e764448f359d2aced62345be3e387 (diff)
downloadopenembedded-65e509aeddd26a6829ee10aa21fa20d6fd3def3e.tar.gz
gcc-4.3/4.4: correct flags passed to native parts of the build
Target CFLAGS (LIBCFLAGS in fact) are leaking into native parts of the build. Fix that (thus making gcc buildable for ppc, e.g.). Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/gcc/files')
-rw-r--r--recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch b/recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch
new file mode 100644
index 0000000000..8a2a4c4040
--- /dev/null
+++ b/recipes/gcc/files/gcc-4.3.3-fix-EXTRA_BUILD.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.3.3/Makefile.in
+===================================================================
+--- gcc-4.3.3.orig/Makefile.in 2010-06-16 18:04:38.379008150 +0400
++++ gcc-4.3.3/Makefile.in 2010-06-16 18:05:29.115006261 +0400
+@@ -148,6 +148,7 @@
+ # built for the build system to override those in BASE_FLAGS_TO_PASSS.
+ EXTRA_BUILD_FLAGS = \
+ CFLAGS="$(CFLAGS_FOR_BUILD)" \
++ LIBCFLAGS="$(CFLAGS_FOR_BUILD)" \
+ LDFLAGS="$(LDFLAGS_FOR_BUILD)"
+
+ # This is the list of directories to built for the host system.