aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.3.3
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-07-25 22:07:10 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-14 12:54:52 +0200
commitc9da5bb8400a2290af95402ee73ad53f642894b8 (patch)
tree8df492b7607cbddcc625de8de2edc25d4101d457 /recipes/gcc/gcc-4.3.3
parenteb973ef9d548f1aaa149ebead08e6ecbbc6f58f6 (diff)
downloadopenembedded-c9da5bb8400a2290af95402ee73ad53f642894b8.tar.gz
gcc4.3.x: patch Makefile.in for cross compile badness
When compiling gcc target code make passes -I(GMPINC) but this one points to the host dir (it is set to HOST_GMPINC which in oe points to tmp/sysroots/i686-linux/usr/include). This patch breaks the env var $(INCLUDES) in two and only uses the TARGET specific part for compiling libgcc and the crt stuff. The patch has been verified by baking all affected recipes with bitbake -c configure -b recipe Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-4.3.3')
-rw-r--r--recipes/gcc/gcc-4.3.3/Makefile.in.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.3.3/Makefile.in.patch b/recipes/gcc/gcc-4.3.3/Makefile.in.patch
new file mode 100644
index 0000000000..4c11a64b2d
--- /dev/null
+++ b/recipes/gcc/gcc-4.3.3/Makefile.in.patch
@@ -0,0 +1,29 @@
+Index: gcc-4.3.1/gcc/Makefile.in
+===================================================================
+--- gcc-4.3.1.orig/gcc/Makefile.in
++++ gcc-4.3.1/gcc/Makefile.in
+@@ -575,7 +575,7 @@ LIBGCC2_INCLUDES =
+ TARGET_LIBGCC2_CFLAGS =
+
+ # Options to use when compiling crtbegin/end.
+-CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(INCLUDES) $(MULTILIB_CFLAGS) -g0 \
++CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(TARGET_INCLUDES) $(MULTILIB_CFLAGS) -g0 \
+ -finhibit-size-directive -fno-inline-functions -fno-exceptions \
+ -fno-zero-initialized-in-bss -fno-toplevel-reorder -fno-tree-vectorize \
+ $(INHIBIT_LIBC_CFLAGS)
+@@ -901,9 +901,13 @@ BUILD_ERRORS = build/errors.o
+ # -I$(@D) and -I$(srcdir)/$(@D) cause the subdirectory of the file
+ # currently being compiled, in both source trees, to be examined as well.
+ # libintl.h will be found in ../intl if we are using the included libintl.
+-INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \
++#
++# TARGET_INCLUDES is added to avoid that GMPINC (which points to the host
++# include dir) is used for compiling libgcc.a
++TARGET_INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \
+ -I$(srcdir)/../include @INCINTL@ \
+- $(CPPINC) $(GMPINC) $(DECNUMINC)
++ $(CPPINC) $(DECNUMINC)
++INCLUDES = $(TARGET_INCLUDES) $(GMPINC)
+
+ .c.o:
+ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) $< $(OUTPUT_OPTION)