aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gcc/gcc-canadian-sdk_4.2.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-canadian-sdk_4.2.4.bb')
-rw-r--r--recipes/gcc/gcc-canadian-sdk_4.2.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
new file mode 100644
index 0000000000..ae3245bf7f
--- /dev/null
+++ b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
@@ -0,0 +1,26 @@
+inherit canadian-sdk
+
+PR = "r1"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+
+PACKAGES = "${PN}"
+
+require gcc-${PV}.inc
+
+# Correct gmp / mpfr
+DEPENDS = "gmp-canadian mpfr-canadian"
+
+require gcc-configure-canadian-sdk.inc
+require gcc-package-canadian-sdk.inc
+
+SRC_URI_append = "file://fortran-cross-compile-hack.patch;patch=1 \
+ file://pr22133-mingw-path-fixup.patch;patch=1 \
+ file://pr33281-mingw-host-fragment.patch;patch=1 \
+ file://pr35916-mingw-__USE_MINGW_ACCESS-everywhere.patch;patch=1 \
+ file://canadian-build-modules-configure.patch;patch=1 \
+"
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_LIBDIR}"