summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc_svn.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-04-06 12:16:23 -0700
committerKhem Raj <raj.khem@gmail.com>2009-04-06 12:16:23 -0700
commit877fed8078d379d213290b791a8a1282867f5061 (patch)
tree7ff5220fd262e343cc3b70634b41771d14580cdd /recipes/gcc/gcc_svn.bb
parentfe6822f3e85d5b14586d747c72b4e0395d981ea9 (diff)
downloadopenembedded-877fed8078d379d213290b791a8a1282867f5061.tar.gz
gcc-svn: Add recipe to build bleeding edge gcc.
Diffstat (limited to 'recipes/gcc/gcc_svn.bb')
-rw-r--r--recipes/gcc/gcc_svn.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/gcc/gcc_svn.bb b/recipes/gcc/gcc_svn.bb
new file mode 100644
index 0000000000..55725b0044
--- /dev/null
+++ b/recipes/gcc/gcc_svn.bb
@@ -0,0 +1,13 @@
+PR = "r0"
+require gcc-${PV}.inc
+require gcc-configure-target.inc
+require gcc-package-target.inc
+
+# Gcc 4.3.3 installs crt* in a '4.3.1' dir....
+FILES_${PN} += "\
+ ${gcclibdir}/${TARGET_SYS}/*/*.o \
+"
+
+SRC_URI_append = "file://fortran-cross-compile-hack.patch;patch=1"
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"