aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-12 13:05:20 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-12 16:18:53 -0700
commit56ca890cdd6faff2afa66931fc31376d2d9afa87 (patch)
tree9fd8aff483cdd4f88f6a34db0f4d5b1e44522e10 /recipes/gcc
parent0c4cf4dcdebc57ec1a0f94f65f2a66bb31b17389 (diff)
downloadopenembedded-56ca890cdd6faff2afa66931fc31376d2d9afa87.tar.gz
gcc-configure-common.inc: Fiddle with NATIVE_SYSTEM_HEADER_DIR only form cross gcc build
* target gcc does not like the NATIVE_SYSTEM_HEADER_DIR being tweaked. for now conditionalize it so it gets included only for cross builds it could be that target gcc for micro wont work because it needs headers in /usr/include and the actual headers are in /include Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-configure-common.inc24
1 files changed, 14 insertions, 10 deletions
diff --git a/recipes/gcc/gcc-configure-common.inc b/recipes/gcc/gcc-configure-common.inc
index fb792a8a88..a0a7dfab74 100644
--- a/recipes/gcc/gcc-configure-common.inc
+++ b/recipes/gcc/gcc-configure-common.inc
@@ -80,16 +80,20 @@ do_configure () {
sed -i 's/^LDFLAGS = $/LDFLAGS = @LDFLAGS@/' ${S}/Makefile.tpl
(cd ${S} && gnu-configize) || die "failure running gnu-configize"
- # splice our idea of where the headers live into gcc's world
- echo "NATIVE_SYSTEM_HEADER_DIR = ${layout_includedir}" > ${T}/t-oe
- sed 's%^tmake_file=.*$%& ${T}/t-oe%' < ${S}/gcc/Makefile.in >${S}/gcc/Makefile.in.new
- mv ${S}/gcc/Makefile.in.new ${S}/gcc/Makefile.in
- cat ${S}/gcc/defaults.h | grep -v "\#endif.*GCC_DEFAULTS_H" > ${S}/gcc/defaults.h.new
- echo "#ifndef STANDARD_INCLUDE_DIR" >> ${S}/gcc/defaults.h.new
- echo "#define STANDARD_INCLUDE_DIR \"${layout_includedir}\"" >> ${S}/gcc/defaults.h.new
- echo "#endif" >> ${S}/gcc/defaults.h.new
- echo "#endif /* ! GCC_DEFAULTS_H */" >> ${S}/gcc/defaults.h.new
- mv ${S}/gcc/defaults.h.new ${S}/gcc/defaults.h
+
+ if [ "${HOST_SYS}" != "${TARGET_SYS}" ]; then
+ # splice our idea of where the headers live into gcc's world
+ echo "NATIVE_SYSTEM_HEADER_DIR = ${layout_includedir}" > ${T}/t-oe
+ sed 's%^tmake_file=.*$%& ${T}/t-oe%' < ${S}/gcc/Makefile.in >${S}/gcc/Makefile.in.new
+ mv ${S}/gcc/Makefile.in.new ${S}/gcc/Makefile.in
+ cat ${S}/gcc/defaults.h | grep -v "\#endif.*GCC_DEFAULTS_H" > ${S}/gcc/defaults.h.new
+ echo "#ifndef STANDARD_INCLUDE_DIR" >> ${S}/gcc/defaults.h.new
+ echo "#define STANDARD_INCLUDE_DIR \"${layout_includedir}\"" >> ${S}/gcc/defaults.h.new
+ echo "#endif" >> ${S}/gcc/defaults.h.new
+ echo "#endif /* ! GCC_DEFAULTS_H */" >> ${S}/gcc/defaults.h.new
+ mv ${S}/gcc/defaults.h.new ${S}/gcc/defaults.h
+ fi
+
oe_runconf
# make sure that no @LDFLAG@ is left in the generated Makefile