summaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-06-19 19:53:10 -0400
committerTom Rini <trini@embeddedalley.com>2009-06-19 19:53:10 -0400
commitaf245faf6ddef5286f17cf0a292d91ec15fdecb1 (patch)
treed6ed3fcf43007d0bb469f0cee1c116f677316d31 /recipes/gcc
parent0ccf91c95b3f21a6ada8630c9b205f8a780f5420 (diff)
downloadopenembedded-af245faf6ddef5286f17cf0a292d91ec15fdecb1.tar.gz
gcc-4.3.1: Switch to INC_PR
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-4.3.1.inc2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc_4.3.1.bb2
4 files changed, 5 insertions, 3 deletions
diff --git a/recipes/gcc/gcc-4.3.1.inc b/recipes/gcc/gcc-4.3.1.inc
index d5390d7f27..f475eba417 100644
--- a/recipes/gcc/gcc-4.3.1.inc
+++ b/recipes/gcc/gcc-4.3.1.inc
@@ -7,6 +7,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r18"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
file://fedora/gcc43-ia64-libunwind.patch;patch=1;pnum=0 \
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.1.bb b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
index 45557b6003..27a7ae0a7f 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r15"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross_4.3.1.bb b/recipes/gcc/gcc-cross_4.3.1.bb
index 2764039081..398ee2ee79 100644
--- a/recipes/gcc/gcc-cross_4.3.1.bb
+++ b/recipes/gcc/gcc-cross_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r18"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc_4.3.1.bb b/recipes/gcc/gcc_4.3.1.bb
index af35244ec1..2153f272ee 100644
--- a/recipes/gcc/gcc_4.3.1.bb
+++ b/recipes/gcc/gcc_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r12"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc