aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdb/files
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-15 16:48:51 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-15 18:38:20 +0400
commit48c3c12e764e706ce8148aaf4c0098c675f9da41 (patch)
tree47a8c0e7675e8faa64cbab3e3a89364e1d53331b /recipes/gdb/files
parent46c758aca15a51bafdd98bce70a9281451bb8d9d (diff)
downloadopenembedded-48c3c12e764e706ce8148aaf4c0098c675f9da41.tar.gz
gdb: fix building of sim/ppc
One shouldn't depend on $(LIBS) value, as it contains -lz-like things, not only filenames. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/gdb/files')
-rw-r--r--recipes/gdb/files/gdb-fix-sim-ppc.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/gdb/files/gdb-fix-sim-ppc.patch b/recipes/gdb/files/gdb-fix-sim-ppc.patch
new file mode 100644
index 0000000000..9457991339
--- /dev/null
+++ b/recipes/gdb/files/gdb-fix-sim-ppc.patch
@@ -0,0 +1,13 @@
+Index: gdb-7.1/sim/ppc/Makefile.in
+===================================================================
+--- gdb-7.1.orig/sim/ppc/Makefile.in 2010-06-15 16:37:51.103007443 +0400
++++ gdb-7.1/sim/ppc/Makefile.in 2010-06-15 16:38:07.417068246 +0400
+@@ -551,7 +551,7 @@
+ PACKAGE_OBJ = @sim_pk_obj@
+
+
+-psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBS) $(LIBINTL_DEP)
++psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBINTL_DEP)
+ $(CC) $(CFLAGS) $(SIM_CFLAGS) $(LDFLAGS) -o psim$(EXEEXT) main.o $(TARGETLIB) $(BFD_LIB) $(LIBINTL) $(LIBIBERTY_LIB) $(LIBS)
+
+ run: psim