aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdb
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-08-02 04:09:03 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-02 04:17:44 +0200
commitd7931d9affb51de54069b75ae0ae9648ffdd64fc (patch)
treec4506ffd8c451bc808e356726f608cd855426143 /recipes/gdb
parent5473be7cf9cb34e98539101adda3cf316dd61478 (diff)
downloadopenembedded-d7931d9affb51de54069b75ae0ae9648ffdd64fc.tar.gz
gdb: Add a patch to fix compilation of gdb 6.8
gcc warns about the subscript_array being uninitialized, just memset this area... luckily I can not break much as this is for fortran code.
Diffstat (limited to 'recipes/gdb')
-rw-r--r--recipes/gdb/gdb-6.8/gdb-6.8-fix-compile-karmic.patch22
-rw-r--r--recipes/gdb/gdb-cross-sdk_6.8.bb3
-rw-r--r--recipes/gdb/gdb_6.8.bb3
3 files changed, 26 insertions, 2 deletions
diff --git a/recipes/gdb/gdb-6.8/gdb-6.8-fix-compile-karmic.patch b/recipes/gdb/gdb-6.8/gdb-6.8-fix-compile-karmic.patch
new file mode 100644
index 0000000000..1080b162aa
--- /dev/null
+++ b/recipes/gdb/gdb-6.8/gdb-6.8-fix-compile-karmic.patch
@@ -0,0 +1,22 @@
+fix this on karmic
+
+cc1: warnings being treated as errors
+/home/ich/build/arm/armv5t/tmp/work/i686-armv5te-sdk-oe-linux-gnueabi/gdb-cross-sdk-6.8-r2/gdb-6.8/gdb/eval.c: In function 'evaluate_subexp_standard':
+/home/ich/build/arm/armv5t/tmp/work/i686-armv5te-sdk-oe-linux-gnueabi/gdb-cross-sdk-6.8-r2/gdb-6.8/gdb/eval.c:1705: error: 'subscript_array' may be used uninitialized in this function
+/home/ich/build/arm/armv5t/tmp/work/i686-armv5te-sdk-oe-linux-gnueabi/gdb-cross-sdk-6.8-r2/gdb-6.8/gdb/eval.c:1644: note: 'subscript_array' was declared here
+
+
+
+Index: gdb-6.8/gdb/eval.c
+===================================================================
+--- gdb-6.8.orig/gdb/eval.c 2009-08-02 03:25:20.000000000 +0200
++++ gdb-6.8/gdb/eval.c 2009-08-02 03:53:39.000000000 +0200
+@@ -1656,6 +1656,8 @@
+ if (nargs != ndimensions)
+ error (_("Wrong number of subscripts"));
+
++ memset(&subscript_array, 0, sizeof(subscript_array));
++
+ /* Now that we know we have a legal array subscript expression
+ let us actually find out where this element exists in the array. */
+
diff --git a/recipes/gdb/gdb-cross-sdk_6.8.bb b/recipes/gdb/gdb-cross-sdk_6.8.bb
index 6aed03d639..66e1454779 100644
--- a/recipes/gdb/gdb-cross-sdk_6.8.bb
+++ b/recipes/gdb/gdb-cross-sdk_6.8.bb
@@ -1,6 +1,7 @@
require gdb-cross.inc
-SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0"
+SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0 \
+ file://gdb-6.8-fix-compile-karmic.patch;patch=1"
DEPENDS = "ncurses-sdk"
diff --git a/recipes/gdb/gdb_6.8.bb b/recipes/gdb/gdb_6.8.bb
index afa4286c2e..ff14c0f31f 100644
--- a/recipes/gdb/gdb_6.8.bb
+++ b/recipes/gdb/gdb_6.8.bb
@@ -1,6 +1,7 @@
require gdb.inc
LICENSE = "GPLv3"
-SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0"
+SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0 \
+ file://gdb-6.8-fix-compile-karmic.patch;patch=1"
PR = "r3"