summaryrefslogtreecommitdiffstats
path: root/recipes/gdb
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-07-14 16:16:26 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-07-14 16:16:26 +0400
commit10fabfa670e4e49a9c9a025d94a87ef0d9c86cc0 (patch)
treedfe0d5662d9f849ccd3c2f2c23654e03c57d788f /recipes/gdb
parent1a35b6063591e39cb54f30188a0f8baa36c5f61b (diff)
downloadopenembedded-10fabfa670e4e49a9c9a025d94a87ef0d9c86cc0.tar.gz
gdb: stop conflicting with binutils
To stop gdb file conflicts with binutils (in different ways) move removing of bfd/opcodes/libiberty stuff to gdb-common.inc. Also bump PRs to force rebuild. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/gdb')
-rw-r--r--recipes/gdb/gdb-common.inc15
-rw-r--r--recipes/gdb/gdb-cross-sdk.inc15
-rw-r--r--recipes/gdb/gdb-cross_6.3.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.4.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.6.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.7.1.bb2
-rw-r--r--recipes/gdb/gdb-cross_6.8.bb2
-rw-r--r--recipes/gdb/gdb-cross_7.0.bb2
-rw-r--r--recipes/gdb/gdb-cross_7.1.bb2
-rw-r--r--recipes/gdb/gdb_6.3.bb2
-rw-r--r--recipes/gdb/gdb_6.4.bb2
-rw-r--r--recipes/gdb/gdb_6.6.bb2
-rw-r--r--recipes/gdb/gdb_6.7.1.bb2
-rw-r--r--recipes/gdb/gdb_6.8.bb2
-rw-r--r--recipes/gdb/gdb_7.0.bb2
-rw-r--r--recipes/gdb/gdb_7.1.bb2
16 files changed, 33 insertions, 25 deletions
diff --git a/recipes/gdb/gdb-common.inc b/recipes/gdb/gdb-common.inc
index d6e0725189..1e0d7c2e9b 100644
--- a/recipes/gdb/gdb-common.inc
+++ b/recipes/gdb/gdb-common.inc
@@ -20,3 +20,18 @@ export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
S = "${WORKDIR}/gdb-${PV}"
B = "${WORKDIR}/build-${TARGET_SYS}"
+do_install_append() {
+ # these mo files from gdb-cross-sdk clash with files from binutils-cross-sdk
+ # when building sdk archives. Drop them for now as a way to restore toolchains.
+ rm ${D}/${datadir}/locale/*/LC_MESSAGES/{bfd,opcodes}.mo
+
+ # we don't care about these infos, installed from binutils
+ rm -f ${D}/${infodir}/{configure,standards,bfd}.info
+ rm -f ${D}/${infodir}/dir
+
+ # We use libiberty from binutils
+ rm -f ${D}${prefix}/${TARGET_SYS}/lib/libiberty.a
+ rm -f ${D}${libdir}/libiberty.a
+
+}
+
diff --git a/recipes/gdb/gdb-cross-sdk.inc b/recipes/gdb/gdb-cross-sdk.inc
index 797a5add79..b452499a48 100644
--- a/recipes/gdb/gdb-cross-sdk.inc
+++ b/recipes/gdb/gdb-cross-sdk.inc
@@ -11,18 +11,3 @@ do_stage() {
:
}
-do_install_append() {
- # these mo files from gdb-cross-sdk clash with files from binutils-cross-sdk
- # when building sdk archives. Drop them for now as a way to restore toolchains.
- rm ${D}/${datadir}/locale/*/LC_MESSAGES/{bfd,opcodes}.mo
-
- # we don't care about these infos, installed from binutils
- rm -f ${D}/${infodir}/{configure,standards,bfd}.info
- rm -f ${D}/${infodir}/dir
-
- # We use libiberty from binutils
- rm -f ${D}${prefix}/${TARGET_SYS}/lib/libiberty.a
- rm -f ${D}${libdir}/libiberty.a
-
-}
-
diff --git a/recipes/gdb/gdb-cross_6.3.bb b/recipes/gdb/gdb-cross_6.3.bb
index 937b669cbe..dd066fbe5e 100644
--- a/recipes/gdb/gdb-cross_6.3.bb
+++ b/recipes/gdb/gdb-cross_6.3.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv2"
-PR = "r3"
+PR = "r4"
SRC_URI += "file://sim-install-makefile.patch \
file://sim-install-makefile-common.patch"
diff --git a/recipes/gdb/gdb-cross_6.4.bb b/recipes/gdb/gdb-cross_6.4.bb
index 8fe4bce858..268e210021 100644
--- a/recipes/gdb/gdb-cross_6.4.bb
+++ b/recipes/gdb/gdb-cross_6.4.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
SRC_URI[md5sum] = "7dc98022ee96bba5331f195dc8a5491a"
SRC_URI[sha256sum] = "719f2bbd79d55cdd6f5e31b49cec49df71ddb32a4439dba678de0e09330096da"
diff --git a/recipes/gdb/gdb-cross_6.6.bb b/recipes/gdb/gdb-cross_6.6.bb
index b9a9f5fee8..d91c030474 100644
--- a/recipes/gdb/gdb-cross_6.6.bb
+++ b/recipes/gdb/gdb-cross_6.6.bb
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv2"
-PR = "r3"
+PR = "r4"
SRC_URI += "file://early_debug_in_nptl.patch;striplevel=0"
diff --git a/recipes/gdb/gdb-cross_6.7.1.bb b/recipes/gdb/gdb-cross_6.7.1.bb
index 9b156a28ea..ccc01d120f 100644
--- a/recipes/gdb/gdb-cross_6.7.1.bb
+++ b/recipes/gdb/gdb-cross_6.7.1.bb
@@ -1,6 +1,8 @@
require gdb-cross.inc
LICENSE = "GPLv3"
+PR = "r1"
+
DEFAULT_PREFERENCE_avr32 = "99"
SRC_URI_avr32 = " http://avr32linux.org/twiki/pub/Main/GDBPatches/gdb-6.7.1.atmel.1.0.3.tar.bz2"
S_avr32 = "${WORKDIR}/gdb-6.7.1.atmel.1.0.3"
diff --git a/recipes/gdb/gdb-cross_6.8.bb b/recipes/gdb/gdb-cross_6.8.bb
index f943bc27bc..dba7c48481 100644
--- a/recipes/gdb/gdb-cross_6.8.bb
+++ b/recipes/gdb/gdb-cross_6.8.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "file://gcc-4.3-build-error.patch;striplevel=0 \
file://gdb-6.8-fix-compile-karmic.patch"
-PR = "r3"
+PR = "r4"
SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb-cross_7.0.bb b/recipes/gdb/gdb-cross_7.0.bb
index 421403aa00..026a7c05ce 100644
--- a/recipes/gdb/gdb-cross_7.0.bb
+++ b/recipes/gdb/gdb-cross_7.0.bb
@@ -1,6 +1,8 @@
require gdb-cross.inc
LICENSE = "GPLv3"
+PR = "r1"
+
SRC_URI += " \
file://gdb-6.8-fix-compile-karmic.patch"
diff --git a/recipes/gdb/gdb-cross_7.1.bb b/recipes/gdb/gdb-cross_7.1.bb
index bd2b704480..64a1b5799b 100644
--- a/recipes/gdb/gdb-cross_7.1.bb
+++ b/recipes/gdb/gdb-cross_7.1.bb
@@ -1,6 +1,8 @@
require gdb-cross.inc
LICENSE = "GPLv3"
+PR = "r1"
+
SRC_URI += " \
file://gdb-6.8-fix-compile-karmic.patch \
file://gdb-fix-sim-ppc.patch \
diff --git a/recipes/gdb/gdb_6.3.bb b/recipes/gdb/gdb_6.3.bb
index 01fb150c5e..7a227fcec0 100644
--- a/recipes/gdb/gdb_6.3.bb
+++ b/recipes/gdb/gdb_6.3.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv2"
-PR = "r4"
+PR = "r5"
SRC_URI[md5sum] = "812de9e756d53c749ea5516d9ffa5905"
SRC_URI[sha256sum] = "c06bf9715436b3a28c189163aa5ca42b46af8286659827f033eaaf7d8b1fc342"
diff --git a/recipes/gdb/gdb_6.4.bb b/recipes/gdb/gdb_6.4.bb
index 022b8cf955..ff9e3d45bb 100644
--- a/recipes/gdb/gdb_6.4.bb
+++ b/recipes/gdb/gdb_6.4.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv2"
-PR = "r2"
+PR = "r3"
SRC_URI[md5sum] = "7dc98022ee96bba5331f195dc8a5491a"
SRC_URI[sha256sum] = "719f2bbd79d55cdd6f5e31b49cec49df71ddb32a4439dba678de0e09330096da"
diff --git a/recipes/gdb/gdb_6.6.bb b/recipes/gdb/gdb_6.6.bb
index 7f18882079..dab1c7df7e 100644
--- a/recipes/gdb/gdb_6.6.bb
+++ b/recipes/gdb/gdb_6.6.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv2"
-PR = "r5"
+PR = "r6"
SRC_URI += "file://early_debug_in_nptl.patch;striplevel=0"
diff --git a/recipes/gdb/gdb_6.7.1.bb b/recipes/gdb/gdb_6.7.1.bb
index ec99c3fbcd..5fe7bcdec9 100644
--- a/recipes/gdb/gdb_6.7.1.bb
+++ b/recipes/gdb/gdb_6.7.1.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv3"
-PR = "r1"
+PR = "r2"
DEFAULT_PREFERENCE_avr32 = "99"
SRC_URI_avr32 = " http://avr32linux.org/twiki/pub/Main/GDBPatches/gdb-6.7.1.atmel.1.0.3.tar.bz2"
diff --git a/recipes/gdb/gdb_6.8.bb b/recipes/gdb/gdb_6.8.bb
index 9d6d54fb81..51310f3c0e 100644
--- a/recipes/gdb/gdb_6.8.bb
+++ b/recipes/gdb/gdb_6.8.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "file://gcc-4.3-build-error.patch;striplevel=0 \
file://gdb-6.8-fix-compile-karmic.patch"
-PR = "r3"
+PR = "r4"
SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb_7.0.bb b/recipes/gdb/gdb_7.0.bb
index 72a78db134..df38a5f87e 100644
--- a/recipes/gdb/gdb_7.0.bb
+++ b/recipes/gdb/gdb_7.0.bb
@@ -1,6 +1,8 @@
require gdb.inc
LICENSE = "GPLv3"
+PR = "r1"
+
SRC_URI += "\
file://gdb-6.8-fix-compile-karmic.patch"
diff --git a/recipes/gdb/gdb_7.1.bb b/recipes/gdb/gdb_7.1.bb
index e829b9bd6d..0a2abc7db3 100644
--- a/recipes/gdb/gdb_7.1.bb
+++ b/recipes/gdb/gdb_7.1.bb
@@ -1,7 +1,7 @@
require gdb.inc
LICENSE = "GPLv3"
-PR = "r1"
+PR = "r2"
SRC_URI += "file://gdb-6.8-fix-compile-karmic.patch \
file://gdb-tcsetpgrp.patch \