aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/geos
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-03-23 00:30:51 -0700
committerKhem Raj <raj.khem@gmail.com>2010-03-23 00:34:24 -0700
commitc73ddd13c8eb7ee231b69af0312341cf227b102d (patch)
tree3a82697dedaf8ad83f1d0d9e0db0b2721cba2d98 /recipes/geos
parent1a482af394a8ddfbe1d576d4d2b73510b8fdfdee (diff)
downloadopenembedded-c73ddd13c8eb7ee231b69af0312341cf227b102d.tar.gz
geos: Add recipe for 3.2.0
* The patch is added to get it compiling on ARM. * Moved the old 2.2.3 based recipe to 3.2.0. * Fixed the recipe for bitbake parsing errors in LICENSE field. * Added patch needed for compiling to succeed on ARM. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/geos')
-rw-r--r--recipes/geos/files/geos-arm.patch22
-rw-r--r--recipes/geos/geos_2.2.3+3.0.0rc4.bb21
-rw-r--r--recipes/geos/geos_3.2.0.bb20
3 files changed, 42 insertions, 21 deletions
diff --git a/recipes/geos/files/geos-arm.patch b/recipes/geos/files/geos-arm.patch
new file mode 100644
index 0000000000..6ef9f67345
--- /dev/null
+++ b/recipes/geos/files/geos-arm.patch
@@ -0,0 +1,22 @@
+This patch is taken from
+http://trac.osgeo.org/geos/ticket/222
+It only applies to ARM EABI systems for now
+If its needed on other architectures then we could
+remove the ifdef part.
+
+-Khem
+
+Index: geos-3.2.0/source/inlines.cpp
+===================================================================
+--- geos-3.2.0.orig/source/inlines.cpp 2010-03-23 00:22:29.612408075 -0700
++++ geos-3.2.0/source/inlines.cpp 2010-03-23 00:25:13.399917727 -0700
+@@ -59,7 +59,9 @@
+ #include <geos/geom/CoordinateArraySequenceFactory.inl>
+ #include <geos/noding/SegmentString.inl>
+ #include <geos/noding/snapround/HotPixel.inl>
++#if ! defined(__ARM_EABI__)
+ #include <geos/noding/snapround/MCIndexSnapRounder.inl>
++#endif // !defined __ARM_EABI__
+ #include <geos/noding/MCIndexNoder.inl>
+
+ #endif // defined __CYGWIN__
diff --git a/recipes/geos/geos_2.2.3+3.0.0rc4.bb b/recipes/geos/geos_2.2.3+3.0.0rc4.bb
deleted file mode 100644
index 90bcc4b384..0000000000
--- a/recipes/geos/geos_2.2.3+3.0.0rc4.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS)."
-HOMEPAGE = "http://geos.refractions.net/"
-LICENSE = "GPLv2""
-
-DEPENDS = "boost"
-
-PR = "r1"
-
-SRC_URI = "http://geos.refractions.net/geos-3.0.0rc4.tar.bz2"
-
-S = "${WORKDIR}/geos-3.0.0rc4"
-
-inherit autotools pkgconfig lib_package binconfig
-
-EXTRA_OECONF = "--disable-swig"
-
-do_stage() {
- autotools_stage_all
-}
-
-
diff --git a/recipes/geos/geos_3.2.0.bb b/recipes/geos/geos_3.2.0.bb
new file mode 100644
index 0000000000..832452f71d
--- /dev/null
+++ b/recipes/geos/geos_3.2.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS)."
+HOMEPAGE = "http://geos.refractions.net/"
+LICENSE = "LGPL"
+
+DEPENDS = "boost"
+
+PR = "r0"
+
+SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2;name=geos \
+ file://geos-arm.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/geos-${PV}"
+
+inherit autotools pkgconfig lib_package binconfig
+
+EXTRA_OECONF = "--disable-swig"
+SRC_URI[geos.md5sum] = "bfad7129680f0107b6ca9a2b92a2c440"
+SRC_URI[geos.sha256sum] = "0a43b76429fd94fd572d79869f3ca5acdf44a9fa73844aa655016f09aaa1e6c7"
+