aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/git
diff options
context:
space:
mode:
authorYann Dirson <ydirson@altern.org>2010-09-15 11:27:48 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-21 23:03:40 -0700
commit2823e121e80a65006a642f0f067f63f9605ff32a (patch)
treefa5b7470df56ac544fdf574d3a2037cac09ac74f /recipes/git
parent287f5ec79cf223238652ad8cfd9e004fd08305e5 (diff)
downloadopenembedded-2823e121e80a65006a642f0f067f63f9605ff32a.tar.gz
git: activate gitk.
It does not work perfectly (complains about possible problems in the tcl package), and buttons are huge, but it allows to browse history. git-gui OTOH does not start at all, it only complains that tk is not correctly installed, so it is commented out. Signed-off-by: Yann Dirson <ydirson@altern.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/git')
-rw-r--r--recipes/git/git-native_1.7.0.2.bb1
-rw-r--r--recipes/git/git.inc2
-rw-r--r--recipes/git/git_1.7.0.2.bb22
3 files changed, 21 insertions, 4 deletions
diff --git a/recipes/git/git-native_1.7.0.2.bb b/recipes/git/git-native_1.7.0.2.bb
index 5a4e8ddd9a..6dd14cb791 100644
--- a/recipes/git/git-native_1.7.0.2.bb
+++ b/recipes/git/git-native_1.7.0.2.bb
@@ -6,3 +6,4 @@ SRC_URI[src.md5sum] = "76518fa774b36de81d160b85fa4f19c1"
SRC_URI[src.sha256sum] = "5601df7fc282fdd66de196b282694eb77dcfc50438f01587de144b3ead1a6b2f"
EXTRA_OECONF_append = " --without-python"
+EXTRA_OEMAKE = "NO_TCLTK=1"
diff --git a/recipes/git/git.inc b/recipes/git/git.inc
index 8275adb1a2..bbbd7e966a 100644
--- a/recipes/git/git.inc
+++ b/recipes/git/git.inc
@@ -8,8 +8,6 @@ S = "${WORKDIR}/git-${PV}"
inherit autotools
-EXTRA_OEMAKE = "NO_TCLTK=1"
-
do_install () {
oe_runmake install DESTDIR="${D}" bindir=${bindir} \
template_dir=${datadir}/git-core/templates \
diff --git a/recipes/git/git_1.7.0.2.bb b/recipes/git/git_1.7.0.2.bb
index b1ccd6cb36..8f902e774a 100644
--- a/recipes/git/git_1.7.0.2.bb
+++ b/recipes/git/git_1.7.0.2.bb
@@ -8,13 +8,13 @@ SRC_URI += "file://git-less-hardlinks.diff"
EXTRA_OECONF += "ac_cv_snprintf_returns_bogus=no ac_cv_c_c99_format=yes"
-DEPENDS = "openssl curl zlib expat"
+DEPENDS = "openssl curl zlib expat tcl-native"
RDEPENDS_${PN} = "findutils sed"
# Dropbear ssh needs a wrapper script, so install openssh-ssh to make it work out of the box
RRECOMMENDS_${PN} = "openssh-ssh"
-PR = "r9"
+PR = "r10"
do_install_append() {
# Fix broken hardlinks
@@ -72,3 +72,21 @@ FILES_${PN}-large += " \
# ${libexecdir}/git-core/git-remote-http \
#"
RDEPENDS_${PN}-large = "${PN}"
+
+# git-tk package with gitk and git-gui
+PACKAGES =+ "${PN}-tk"
+RDEPENDS_${PN}-tk = "${PN} tk tcl"
+EXTRA_OEMAKE = "TCL_PATH=${STAGING_BINDIR_CROSS}/tclsh"
+FILES_${PN}-tk = " \
+ ${bindir}/gitk \
+ ${datadir}/gitk \
+"
+# git gui does not start at all at this time
+#FILES_${PN}-tk += " \
+# ${libexecdir}/git-core/git-gui \
+# ${libexecdir}/git-core/git-gui--askpass \
+# ${datadir}/git-gui \
+#"
+#PACKAGES += "${PN}-tk-locale"
+#PACKAGES_DYNAMIC = "${PN}-tk-locale-*"
+#FILES_${PN}-tk-locale = "${datadir}/git-gui/lib/msgs"