aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/git
diff options
context:
space:
mode:
authorYann Dirson <ydirson@altern.org>2010-09-15 11:27:47 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-21 23:03:39 -0700
commit287f5ec79cf223238652ad8cfd9e004fd08305e5 (patch)
tree60033ecefc1ac0a2ab1cfaf829217524bbb4df7b /recipes/git
parent50fc7462c48dec780900378149ac937bc41c45fa (diff)
downloadopenembedded-287f5ec79cf223238652ad8cfd9e004fd08305e5.tar.gz
git: split space-hungry rarely-used commands into -perltools and -large packages.
This trims the main package by ~75%, and split of all perl scripts allows to spare the installation of perl, which is no small bargain either. Note that git-remote-http triggers a strange bug (OE#5465), so it is not split out for now. Also drop cpio dependency, which has been unneeded since a number of git revisions. Tested rapidly on shr/testing: seen no problem doing clone/commit/amend/reset/ revert/log/status/diff/rebase -i/conflict resolution. Signed-off-by: Yann Dirson <ydirson@altern.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/git')
-rw-r--r--recipes/git/git_1.7.0.2.bb46
1 files changed, 44 insertions, 2 deletions
diff --git a/recipes/git/git_1.7.0.2.bb b/recipes/git/git_1.7.0.2.bb
index 0ca44b581c..b1ccd6cb36 100644
--- a/recipes/git/git_1.7.0.2.bb
+++ b/recipes/git/git_1.7.0.2.bb
@@ -9,12 +9,12 @@ EXTRA_OECONF += "ac_cv_snprintf_returns_bogus=no ac_cv_c_c99_format=yes"
DEPENDS = "openssl curl zlib expat"
-RDEPENDS_${PN} = "perl perl-module-file-path cpio findutils sed"
+RDEPENDS_${PN} = "findutils sed"
# Dropbear ssh needs a wrapper script, so install openssh-ssh to make it work out of the box
RRECOMMENDS_${PN} = "openssh-ssh"
-PR = "r8"
+PR = "r9"
do_install_append() {
# Fix broken hardlinks
@@ -30,3 +30,45 @@ do_install_append() {
}
FILES_${PN}-dbg += "${libexecdir}/git-core/.debug"
+
+PACKAGES =+ "${PN}-perltools"
+FILES_${PN}-perltools += " \
+ ${libexecdir}/git-core/git-add--interactive \
+ ${libexecdir}/git-core/git-archimport \
+ ${libexecdir}/git-core/git-cvsexportcommit \
+ ${libexecdir}/git-core/git-cvsimport \
+ ${libexecdir}/git-core/git-cvsserver \
+ ${bindir}/git-cvsserver \
+ ${libexecdir}/git-core/git-difftool \
+ ${libexecdir}/git-core/git-relink \
+ ${libexecdir}/git-core/git-send-email \
+ ${libexecdir}/git-core/git-svn \
+ ${datadir}/perl \
+"
+RDEPENDS_${PN}-perltools = "${PN} perl perl-module-file-path findutils"
+
+PACKAGES =+ "${PN}-large"
+FILES_${PN}-large += " \
+ ${libexecdir}/git-core/git-http-backend \
+ ${libexecdir}/git-core/git-daemon \
+ ${libexecdir}/git-core/git-http-push \
+ ${libexecdir}/git-core/git-quiltimport \
+ ${libexecdir}/git-core/git-request-pull \
+ ${libexecdir}/git-core/git-shell \
+ ${bindir}/git-shell \
+ ${libexecdir}/git-core/git-instaweb \
+ ${libexecdir}/git-core/git-fast-import \
+ ${libexecdir}/git-core/git-imap-send \
+"
+# those might be useful in a less-than-large package ?
+FILES_${PN}-large += " \
+ ${libexecdir}/git-core/git-http-fetch \
+ ${libexecdir}/git-core/git-upload-pack \
+ ${bindir}/git-upload-pack \
+"
+# same here, but adding it causes git to depend on git-large(!)
+# see http://bugs.openembedded.net/show_bug.cgi?id=5465
+#FILES_${PN}-large += " \
+# ${libexecdir}/git-core/git-remote-http \
+#"
+RDEPENDS_${PN}-large = "${PN}"