aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gkdial/gkdial-1.8.1
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gkdial/gkdial-1.8.1
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gkdial/gkdial-1.8.1')
-rw-r--r--recipes/gkdial/gkdial-1.8.1/gkdial-arm.patch11
-rw-r--r--recipes/gkdial/gkdial-1.8.1/gkdial-gladedir.patch11
-rw-r--r--recipes/gkdial/gkdial-1.8.1/gkdial-gpe-su.patch22
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes/gkdial/gkdial-1.8.1/gkdial-arm.patch b/recipes/gkdial/gkdial-1.8.1/gkdial-arm.patch
new file mode 100644
index 0000000000..aa24977762
--- /dev/null
+++ b/recipes/gkdial/gkdial-1.8.1/gkdial-arm.patch
@@ -0,0 +1,11 @@
+--- gkdial-1.8.1.orig/src/main.c 2003-06-27 04:47:54.000000000 +0200
++++ gkdial-1.8.1/src/main.c 2004-06-18 12:30:11.000000000 +0200
+@@ -416,7 +416,7 @@
+ gkdial.add_only = FALSE;
+ gkdial.edit_only = FALSE;
+ gkdial.remove_only = FALSE;
+- char c;
++ int c;
+
+ /*
+ * it seems like poff kills gkdial together with it's children, so
diff --git a/recipes/gkdial/gkdial-1.8.1/gkdial-gladedir.patch b/recipes/gkdial/gkdial-1.8.1/gkdial-gladedir.patch
new file mode 100644
index 0000000000..64b7b15b62
--- /dev/null
+++ b/recipes/gkdial/gkdial-1.8.1/gkdial-gladedir.patch
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2004-06-16 18:27:51.000000000 +0200
++++ Makefile.am 2004-06-16 18:28:09.000000000 +0200
+@@ -7,7 +7,7 @@
+ gkdial.glade \
+ gkdial.gladep
+
+-gladedir = $(DESTDIR)/$(pkgdatadir)/glade
++gladedir = $(pkgdatadir)/glade
+ glade_DATA = gkdial.glade
+
+ install-data-local:
diff --git a/recipes/gkdial/gkdial-1.8.1/gkdial-gpe-su.patch b/recipes/gkdial/gkdial-1.8.1/gkdial-gpe-su.patch
new file mode 100644
index 0000000000..0be396f389
--- /dev/null
+++ b/recipes/gkdial/gkdial-1.8.1/gkdial-gpe-su.patch
@@ -0,0 +1,22 @@
+--- gkdial-1.8.1.orig/src/util.c 2003-06-27 22:30:29.000000000 +0200
++++ gkdial-1.8.1/src/util.c 2004-06-18 16:57:43.000000000 +0200
+@@ -336,13 +336,13 @@
+ gint a;
+ pid_t pid;
+ gchar **command;
++ gchar *fcmd = g_strdup_printf("%s > /dev/null 2>&1",cmd);
+
+- command = g_malloc (sizeof (gchar *) * 5);
+- command[0] = g_strdup ("/usr/bin/gksu");
+- command[1] = g_strdup ("-m");
+- command[2] = g_strdup (msg);
+- command[3] = g_strdup (cmd);
+- command[4] = NULL;
++ command = g_malloc (sizeof (gchar *) * 4);
++ command[0] = g_strdup (PREFIX "/bin/gpe-su");
++ command[1] = g_strdup ("-c");
++ command[2] = fcmd;
++ command[3] = NULL;
+
+ pid = fork ();
+ if (pid == 0)