aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gmp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-20 14:25:22 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-21 13:46:03 -0700
commit03ba2d4f86360abbcfed2a7350a93d3b3777f280 (patch)
tree7c15feaefd312f03d1172323f702cb5162341c7d /recipes/gmp
parent9aad9078dc77425b83aa051d89062f52e2f000b8 (diff)
downloadopenembedded-03ba2d4f86360abbcfed2a7350a93d3b3777f280.tar.gz
gcc-cross,gcc-cross-sdk: Link libmpfr, libgmp, libmpc and libelf statically into gcc
* Generate static version of these libraries Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/gmp')
-rw-r--r--recipes/gmp/gmp.inc7
-rw-r--r--recipes/gmp/gmp_4.2.4.bb14
-rw-r--r--recipes/gmp/gmp_5.0.1.bb5
3 files changed, 15 insertions, 11 deletions
diff --git a/recipes/gmp/gmp.inc b/recipes/gmp/gmp.inc
index 55209f31da..522189d630 100644
--- a/recipes/gmp/gmp.inc
+++ b/recipes/gmp/gmp.inc
@@ -2,6 +2,7 @@ SECTION = "libs"
DESCRIPTION = "GNU multiprecision arithmetic library"
HOMEPAGE = "http://www.swox.com/gmp/"
LICENSE = "GPL LGPL"
+INC_PR = "r1"
SRC_URI = "${GNU_MIRROR}/gmp/gmp-${PV}.tar.bz2;name=gmp \
file://configure.patch \
@@ -11,5 +12,11 @@ inherit autotools
ARM_INSTRUCTION_SET = "arm"
+
+EXTRA_OECONF_append_virtclass-native = " --enable-static"
+
+BBCLASSEXTEND = "native nativesdk"
+NATIVE_INSTALL_WORKS = "1"
+
acpaths = ""
diff --git a/recipes/gmp/gmp_4.2.4.bb b/recipes/gmp/gmp_4.2.4.bb
index af05875075..6eb1ecbd1c 100644
--- a/recipes/gmp/gmp_4.2.4.bb
+++ b/recipes/gmp/gmp_4.2.4.bb
@@ -1,13 +1,13 @@
-INC_PR = "r0"
+require gmp.inc
+
+SRC_URI += "file://sh4-asmfix.patch \
+ file://use-includedir.patch \
+ file://dont_use_mips_h_constraint.patch \
+ "
+
PR = "${INC_PR}.5"
-SRC_URI_append += "file://sh4-asmfix.patch \
- file://use-includedir.patch \
- file://dont_use_mips_h_constraint.patch \
- "
-require gmp.inc
LICENSE = "GPLv3 LGPLv3"
-BBCLASSEXTEND = "nativesdk"
SRC_URI[gmp.md5sum] = "fc1e3b3a2a5038d4d74138d0b9cf8dbe"
SRC_URI[gmp.sha256sum] = "5420b0e558a69a53b36f2b2c70a69f547e075d98366a585fc80cbbcce1efe368"
diff --git a/recipes/gmp/gmp_5.0.1.bb b/recipes/gmp/gmp_5.0.1.bb
index 0b117b1e37..95cb771296 100644
--- a/recipes/gmp/gmp_5.0.1.bb
+++ b/recipes/gmp/gmp_5.0.1.bb
@@ -1,8 +1,5 @@
-INC_PR = "r0"
+require gmp.inc
PR = "${INC_PR}.1"
SRC_URI[gmp.md5sum] = "6bac6df75c192a13419dfd71d19240a7"
SRC_URI[gmp.sha256sum] = "a2a610f01fd3298dc08c87bf30498c2402590e1bcb227fc40b15ee6d280939fb"
-require gmp.inc
LICENSE = "GPLv3 LGPLv3"
-NATIVE_INSTALL_WORKS = "1"
-BBCLASSEXTEND = "native nativesdk"