aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnash/files
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-10-18 21:07:47 +0200
committerLeon Woestenberg <leon@sidebranch.com>2009-10-18 21:08:42 +0200
commit559544e75c5b09d2f51a21d0d7aefbabf50bd58d (patch)
tree33dedce6aa3060d3378001d4d0652ab958ea6065 /recipes/gnash/files
parentf6bb1d830c51b78b3e99619645152add67fad3e9 (diff)
downloadopenembedded-559544e75c5b09d2f51a21d0d7aefbabf50bd58d.tar.gz
gnash: Add gnash-fb 0.8.5, gnash for framebuffer devices.
Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
Diffstat (limited to 'recipes/gnash/files')
-rw-r--r--recipes/gnash/files/gnash-glib-dependency.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/gnash/files/gnash-glib-dependency.patch b/recipes/gnash/files/gnash-glib-dependency.patch
new file mode 100644
index 0000000000..e75026c031
--- /dev/null
+++ b/recipes/gnash/files/gnash-glib-dependency.patch
@@ -0,0 +1,33 @@
+If glib is not brought in via GTK, we still need it for GStreamer. This
+seems an upstream bug in gnash, exposed when the FB GUI is built instead of
+the GTK+ GUI.
+
+Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
+
+Index: gnash-0.8.5/gui/Makefile.am
+===================================================================
+--- gnash-0.8.5.orig/gui/Makefile.am 2009-10-18 20:34:19.000000000 +0200
++++ gnash-0.8.5/gui/Makefile.am 2009-10-18 20:35:14.000000000 +0200
+@@ -137,8 +137,8 @@
+ endif
+
+ if USE_GST_ENGINE
+-AM_CPPFLAGS += $(GSTREAMER_CFLAGS)
+-AM_LDFLAGS += $(GSTREAMER_LIBS)
++AM_CPPFLAGS += $(GSTREAMER_CFLAGS) $(GLIB_CFLAGS)
++AM_LDFLAGS += $(GSTREAMER_LIBS) $(GLIB_LIBS)
+ endif
+
+ # if USE_GUI_FLTK
+Index: gnash-0.8.5/plugin/plugin.h
+===================================================================
+--- gnash-0.8.5.orig/plugin/plugin.h 2009-10-18 20:34:19.000000000 +0200
++++ gnash-0.8.5/plugin/plugin.h 2009-10-18 20:34:58.000000000 +0200
+@@ -44,6 +44,7 @@
+ #ifdef HAVE_GTK2
+ #include <gtk/gtk.h>
+ #endif
++#include <glib.h>
+ #include <string>
+ #include <map>
+ #include "pluginbase.h"